[PTA]习题9-6 按等级统计学生成绩

Posted Spring-_-Bear

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]习题9-6 按等级统计学生成绩相关的知识,希望对你有一定的参考价值。

[PTA]习题9-6 按等级统计学生成绩

本题要求实现一个根据学生成绩设置其等级,并统计不及格人数的简单函数。

函数接口定义:
int set_grade( struct student *p, int n );
其中p是指向学生信息的结构体数组的指针,该结构体的定义为:

struct student{
    int num;
    char name[20];
    int score;
    char grade;
};

n是数组元素个数。学号num、姓名name和成绩score均是已经存储好的。set_grade函数需要根据学生的成绩score设置其等级grade。等级设置:85-100为A,70-84为B,60-69为C,0-59为D。同时,set_grade还需要返回不及格的人数。

裁判测试程序样例:

#include <stdio.h>
#define MAXN 10

struct student{
    int num;
    char name[20];
    int score;
    char grade;
};

int set_grade( struct student *p, int n );

int main()
{   struct student stu[MAXN], *ptr;
    int n, i, count;

    ptr = stu;
    scanf("%d\\n", &n);
    for(i = 0; i < n; i++){
       scanf("%d%s%d", &stu[i].num, stu[i].name, &stu[i].score);
    } 
   count = set_grade(ptr, n);
   printf("The count for failed (<60): %d\\n", count);
   printf("The grades:\\n"); 
   for(i = 0; i < n; i++)
       printf("%d %s %c\\n", stu[i].num, stu[i].name, stu[i].grade);
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:
10
31001 annie 85
31002 bonny 75
31003 carol 70
31004 dan 84
31005 susan 90
31006 paul 69
31007 pam 60
31008 apple 50
31009 nancy 100
31010 bob 78
输出样例:
The count for failed (<60): 1
The grades:
31001 annie A
31002 bonny B
31003 carol B
31004 dan B
31005 susan A
31006 paul C
31007 pam C
31008 apple D
31009 nancy A
31010 bob B

  • 提交结果:

在这里插入图片描述

  • 源码:
#include <stdio.h>
#define MAXN 10

struct student {
    int num;
    char name[20];
    int score;
    char grade;
};

int set_grade(struct student* p, int n);

int main()
{
    struct student stu[MAXN], * ptr;
    int n, i, count;

    ptr = stu;
    scanf("%d\\n", &n);
    for (i = 0; i < n; i++) {
        scanf("%d%s%d", &stu[i].num, stu[i].name, &stu[i].score);
    }
    count = set_grade(ptr, n);
    printf("The count for failed (<60): %d\\n", count);
    printf("The grades:\\n");
    for (i = 0; i < n; i++)
        printf("%d %s %c\\n", stu[i].num, stu[i].name, stu[i].grade);
    return 0;
}

/* 你的代码将被嵌在这里 */
int set_grade(struct student* p, int n)
{
    int fail = 0;   // 不及格人数

    for (int i = 0; i < n; i++)
    {
        if (p[i].score >= 0 && p[i].score <= 59)
        {
            fail++;
            p[i].grade = 'D';
        }
        else if (p[i].score >= 60 && p[i].score <= 69)
        {
            p[i].grade = 'C';
        }
        else if (p[i].score >= 70 && p[i].score <= 84)
        {
            p[i].grade = 'B';
        }
        else if (p[i].score >= 85 && p[i].score <= 100)
        {
            p[i].grade = 'A';
        }
    }

    return fail;
}

以上是关于[PTA]习题9-6 按等级统计学生成绩的主要内容,如果未能解决你的问题,请参考以下文章

PTA的Python练习题-第4章-7 统计学生平均成绩与及格人数

[PTA]习题8-10 输出学生成绩

第四次PTA作业

按等级统计学生成绩

PTA第四次作业

pta第四次作业