[PTA]习题11-1 输出月份英文名
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]习题11-1 输出月份英文名相关的知识,希望对你有一定的参考价值。
[PTA]习题11-1 输出月份英文名
本题要求实现函数,可以返回一个给定月份的英文名称。
函数接口定义:
char *getmonth( int n );
函数getmonth应返回存储了n对应的月份英文名称的字符串头指针。如果传入的参数n不是一个代表月份的数字,则返回空指针NULL。
裁判测试程序样例:
#include <stdio.h>
char *getmonth( int n );
int main()
{
int n;
char *s;
scanf("%d", &n);
s = getmonth(n);
if ( s==NULL ) printf("wrong input!\\n");
else printf("%s\\n", s);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例1:
5
输出样例1:
May
输入样例2:
15
输出样例2:
wrong input!
- 提交结果:
- 源码:
#include <stdio.h>
char* getmonth(int n);
int main()
{
int n;
char* s;
scanf("%d", &n);
s = getmonth(n);
if (s == NULL) printf("wrong input!\\n");
else printf("%s\\n", s);
return 0;
}
/* 你的代码将被嵌在这里 */
char* getmonth(int n)
{
char* s;
switch (n)
{
case 1: s = "January"; break;
case 2: s = "February"; break;
case 3: s = "March"; break;
case 4: s = "April"; break;
case 5: s = "May"; break;
case 6: s = "June"; break;
case 7: s = "July"; break;
case 8: s = "August"; break;
case 9: s = "September"; break;
case 10: s = "October"; break;
case 11: s = "November"; break;
case 12: s = "December"; break;
default: s = NULL;
}
return s;
}
以上是关于[PTA]习题11-1 输出月份英文名的主要内容,如果未能解决你的问题,请参考以下文章