UVA326 LA5434 POJ1538 Extrapolation Using a Difference Table二项式

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA326 LA5434 POJ1538 Extrapolation Using a Difference Table二项式相关的知识,希望对你有一定的参考价值。

Extrapolation Using a Difference Table
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 306 Accepted: 166

Description

A very old technique for extrapolating a sequence of values is based on the use of a difference table. The difference table used in the extrapolation of a sequence of 4 values, say 3, 6, 10, and 15, might be displayed as follows:
在这里插入图片描述

The original sequence of values appears in the first column of the table. Each entry in the second column of the table is formed by computing the difference between the adjacent entries in the first column. These values (in the second column) are called first differences. Each entry in the third column is similarly the difference between the adjacent entries in the second column; the third column entries are naturally called second differences. Computation of the last column in this example should now be obvious (but beware that this value is not always zero). Note that the last column will always contain only a single value. If we begin with a sequence of n values, the completed difference table will have n columns, with the single value in column n representing the single n-1st difference.

To extrapolate using a difference table we assume the n-1st differences are constant (since we have no additional information to refute that assumption). Given that assumption, we can compute the next entry in the n-2nd difference column, the n-3rd difference column, and so forth until we compute the next entry in the first column which, of course, is the next value in the sequence. The table below shows the four additional entries (in boxes) added to the table to compute the next entry in the example sequence, which in this case is 21. We could obviously continue this extrapolation process as far as desired by adding additional entries to the columns using the assumption that the n-1st differences are constant.
在这里插入图片描述

Input

The input for this problem will be a set of extrapolation requests. For each request the input will contain first an integer n, which specifies the number of values in the sequence to be extended. When n is zero your program should terminate. If n is non-zero (it will never be larger than 10), it will be followed by n integers representing the given elements in the sequence. The last item in the input for each extrapolation request is k, the number of extrapolation operations to perform; it will always be at least 1.

Output

In effect, you are to add k entries to each column of the difference table, finally reporting the last value of the sequence computed by such extrapolation. More precisely, assume the first n entries (the given values) in the sequence are numbered 1 through n. Your program is to determine the n+kth value in the sequence by extrapolation of the original sequence k times.

Sample Input

4 3 6 10 15 1
4 3 6 10 15 2
3 2 4 6 20
6 3 9 12 5 18 -4 10
0

Sample Output

Term 5 of the sequence is 21
Term 6 of the sequence is 28
Term 23 of the sequence is 46
Term 16 of the sequence is -319268
Hint

no upper limit is given for k, and you might not be able to acquire enough memory to construct a complete difference table.

Source

North Central North America 1993

问题链接UVA326 LA5434 POJ1538 Extrapolation Using a Difference Table
问题简述:(略)
问题分析:二项式系数问题,暂时不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA326 LA5434 POJ1538 Extrapolation Using a Difference Table */

#include <iostream>

using namespace std;

const int N = 10;
int dp[N][N], a[N];

int clac(int n, int k)
{
    int c = dp[0][n - 1];
    for (int i = 0; i < n; i++)
        a[i] = dp[n - i - 1][i];
    for (int i = 0; i < k; i++) {
        a[n - 1] = c;
        for (int j = n - 2; j >= 0; j--)
            a[j] += a[j + 1];
    }
    return a[0];
}

int main()
{
    int n;
    while (cin >> n && n) {
        for (int i = 0; i < n; i++)
            cin >> dp[i][0];
        for (int i = 1; i < n; i++)
            for (int j = 0; j < n - i; j ++)
                dp[j][i] = dp[j + 1][i - 1] - dp[j][i - 1];

        int k;
        cin >> k;
        cout << "Term " << n + k << " of the sequence is " << clac(n, k) << endl;
    }

    return 0;
}

以上是关于UVA326 LA5434 POJ1538 Extrapolation Using a Difference Table二项式的主要内容,如果未能解决你的问题,请参考以下文章

UVA275 LA5384 POJ1140 Expanding Fractions循环节

HDU1416 POJ1078 UVA653 LA5507 GizilchDFS

UVA12081 LA3413 POJ2769 Reduced ID Numbers同余

UVA619 LA5465 POJ1312 HDU1314 ZOJ1272 Numerically Speaking大数+进制

POJ2106 LA3094 ZOJ2483 Boolean Expressions文本处理

POJ2106 LA3094 ZOJ2483 Boolean Expressions文本处理