UVA12081 LA3413 POJ2769 Reduced ID Numbers同余

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA12081 LA3413 POJ2769 Reduced ID Numbers同余相关的知识,希望对你有一定的参考价值。

Reduced ID Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11934 Accepted: 4666

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

Source

Northwestern Europe 2005

问题链接UVA12081 LA3413 POJ2769 Reduced ID Numbers
问题简述:给定若干个学生的学号,求最小的m,使得每个学生的学号对m取余都不相等。
问题分析:同余问题,枚举法来解决。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA12081 LA3413 POJ2769 Reduced ID Numbers */

#include <stdio.h>
#include <string.h>

const int M = 1e6;
const int G = 300;
int a[G];
bool vis[M];

int main()
{
    int n, g;
    scanf("%d", &n);
    while (n--) {
        scanf("%d", &g);
        for (int i = 0; i < g; i++) scanf("%d", &a[i]);

        int i, m;
        for(m=g;;m++){
            for(i = 0; i < m; i++) vis[i] = false;
            for(i = 0; i < g; i++)
                if(!vis[a[i] % m]) vis[a[i]%m] = true;
                else break;
            if (i == g) break;
        }

        printf("%d\\n", m);
    }

    return 0;
}

以上是关于UVA12081 LA3413 POJ2769 Reduced ID Numbers同余的主要内容,如果未能解决你的问题,请参考以下文章

UVA275 LA5384 POJ1140 Expanding Fractions循环节

HDU1416 POJ1078 UVA653 LA5507 GizilchDFS

UVA619 LA5465 POJ1312 HDU1314 ZOJ1272 Numerically Speaking大数+进制

UVA326 LA5434 POJ1538 Extrapolation Using a Difference Table二项式

poj 2769 感觉♂良好 (单调栈)

poj 2769 Reduced ID Numbers 同余定理