POJ2891 Strange Way to Express Integers线性同余方程
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2891 Strange Way to Express Integers线性同余方程相关的知识,希望对你有一定的参考价值。
Strange Way to Express Integers
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 25867 Accepted: 8533
Description
Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:
Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.
“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”
Since Elina is new to programming, this problem is too difficult for her. Can you help her?
Input
The input contains multiple test cases. Each test cases consists of some lines.
Line 1: Contains the integer k.
Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ i ≤ k).
Output
Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.
Sample Input
2
8 7
11 9
Sample Output
31
Hint
All integers in the input and the output are non-negative and can be represented by 64-bit integral types.
Source
POJ Monthly–2006.07.30, Static
问题链接:POJ2891 Strange Way to Express Integers
问题简述:(略)
问题分析:用扩展欧几里得算法,解线性同余方程。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* POJ2891 Strange Way to Express Integers */
#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
void exgcd(LL a, LL b, LL &d, LL &x, LL &y)
{
if (b) {exgcd(b, a % b, d, x, y); LL t = x; x = y; y = t - a / b * y;}
else {x = 1; y = 0; d = a;}
}
int main()
{
int n;
while (~scanf("%d", &n)) {
LL a1, r1, a2, r2;
int flag = 1;
scanf("%lld%lld", &a1, &r1);
for (int i = 2; i <= n; i++) {
scanf("%lld%lld", &a2, &r2);
LL a = a1, b = a2, d, x, y, c = r2 - r1;
exgcd(a, b, d, x, y);
if (c % d) flag = 0;
LL t = b / d;
x = x * c / d;
x = (x % t + t) % t;
r1 = a1 * x + r1;
a1 = a1 / d * a2;
}
if (flag) printf("%lld\\n", r1);
else printf("-1\\n");
}
return 0;
}
以上是关于POJ2891 Strange Way to Express Integers线性同余方程的主要内容,如果未能解决你的问题,请参考以下文章
POJ 2891 Strange Way to Express Integers
poj 2891 Strange Way to Express Integers 2012-09-05
POJ2891Strange Way to Express Integers(拓展CRT)
POJ2891Strange Way to Express Integers