[PTA]习题9-4 查找书籍
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]习题9-4 查找书籍相关的知识,希望对你有一定的参考价值。
[PTA]习题9-4 查找书籍
给定n本书的名称和定价,本题要求编写程序,查找并输出其中定价最高和最低的书的名称和定价。
输入格式:
输入第一行给出正整数n(<10),随后给出n本书的信息。每本书在一行中给出书名,即长度不超过30的字符串,随后一行中给出正实数价格。题目保证没有同样价格的书。
输出格式:
在一行中按照“价格, 书名”的格式先后输出价格最高和最低的书。价格保留2位小数。
输入样例:
3
Programming in C
21.5
Programming in VB
18.5
Programming in Delphi
25.0
输出样例:
25.00, Programming in Delphi
18.50, Programming in VB
- 提交结果:
- 源码:
#include<stdio.h>
// 书籍信息结构体,使用typedef为struct Book取一个别名为Book
typedef struct Book
{
char name[31]; // 题目给出长度不超过30的字符串,需将字符串结束符'\\0'存入字符串尾,故长度为31
double price;
}Book;
int main(void)
{
Book book[10]; // 书籍信息结构体数组
int n;
int maxIndex, minIndex;
scanf("%d", &n);
getchar(); // 吸收输入n后换行时的换行符
for (int i = 0; i < n; i++)
{
gets(book[i].name);
scanf("%lf", &book[i].price);
getchar(); // 吸收输入书籍价格后换行时的换行符
}
// 假设第一本书即是价格最高最低的书
minIndex = maxIndex = 0;
// 从余下书籍中找到价格最低、最高的书籍,记录其下标
for (int i = 1; i < n; i++)
{
// 找到价格最低的书籍的下标
if (book[i].price < book[minIndex].price)
{
minIndex = i;
}
// 找到价格最高的书籍的下标
if (book[i].price > book[maxIndex].price)
{
maxIndex = i;
}
}
printf("%.2f, %s\\n", book[maxIndex].price, book[maxIndex].name);
printf("%.2f, %s\\n", book[minIndex].price, book[minIndex].name);
return 0;
}
以上是关于[PTA]习题9-4 查找书籍的主要内容,如果未能解决你的问题,请参考以下文章