Problem C
Posted tansanity
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem C相关的知识,希望对你有一定的参考价值。
Problem Description Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.<br><br><center><img src=/data/images/1087-1.jpg></center><br><br>The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.<br>Your task is to output the maximum value according to the given chessmen list.<br>Input Input contains multiple test cases. Each test case is described in a line as follow:<br>N value_1 value_2 …value_N <br>It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.<br>A test case starting with 0 terminates the input and this test case is not to be processed.<br>
Output For each case, print the maximum according to rules, and one line one case.<br>
Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
Sample Output
4 10 3
简单题意: 一项下棋的游戏,可以由两个或以上的玩家开始,每个棋子都是又一个正整数构成,也可以就看成终点或起点。玩家从出发点跳进终点,但有一项规则,就是只能从小的向大的棋子跳,并且玩家不能后退。可以跳过一个棋子,同样也可以跳过多个棋子,也可以直接从起点跳到终点,但是分数就为0了。现在。要求编写一个程序,求出能获得最大分数的跳棋子的方案。 解题思路形成过程: 有难度的动态规划题目,关键在于题意的理解。 sum[i]=num[i]+sum[j],状态方程。所以只需要比较当前的sum[i]是否比其小,如果小的话,把值给当前棋子。最后就能得出最大的分数。 感想: 题意读了好几遍才弄明白一点。动态规划的核心还是不会消失的,所以一步一步就能写出状态方程。 AC代码: #include <iostream>
#include <cstring>
using namespace std;
int main()
int n,sum[1001],num[1001];
while(cin>>n&&n!=0)
for(int i=1;i<=n;i++)
cin>>num[i];
sum[1]=num[1];
int ans=sum[1];
for(int i=2;i<=n;i++)
sum[i]=num[i];
for(int j=1;j<i;j++)
if(num[j]<num[i]&&sum[j]+num[i]>sum[i])
sum[i]=num[i]+sum[j];
if(ans<sum[i])
ans=sum[i];
cout<<ans<<endl;
return 0;
以上是关于Problem C的主要内容,如果未能解决你的问题,请参考以下文章
[ 题解 ] [ 公式 ] F. Teleportation