1039

Posted tookkke

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1039相关的知识,希望对你有一定的参考价值。

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11083    Accepted Submission(s): 5356


Problem Description Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
 
Input The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
 
Output For each password, output whether or not it is acceptable, using the precise format shown in the example.
 
Sample Input
  
   a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end
  
 
Sample Output
  
   <a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.
  





    要认真读题啊

    1.至少要有一个元音;

    2.不能出现3个连续辅音或3个连续元音;

    3.不能有两个连续相同的字母(除了'e'和'o')//最开始就错在这,可以出现'ee'和'oo',但不用去判断三个'e'的情况,因为这已经被条件2给否定了。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

#define MAXN 6666666

using namespace std;

char kkke[MAXN];

inline bool is_vowel(char c)

	switch(c)
	
		case 'a':
		case 'e':
		case 'i':
		case 'o':
		case 'u':
			return true;
		default:
			return false;
	

int main()

	freopen("input.txt","r",stdin);
	freopen("output.txt","w",stdout);
	while(scanf("%s",kkke),strcmp(kkke,"end"))
	
		bool ans=is_vowel(kkke[0]);
		int cnt=1;
	    for(int i=1;kkke[i]!='\\0';i++)
	    
	    	if(!ans&&is_vowel(kkke[i]))ans=true;
	    	//if(kkke[i]==kkke[i-1])
	    	if(kkke[i]!='e'&&kkke[i]!='o'&&kkke[i]==kkke[i-1])
	    	
	    		ans=false;
	    		break;
	    	
	    	
	    	if(is_vowel(kkke[i])==is_vowel(kkke[i-1]))cnt++;
	    	else cnt=1;
	    	if(cnt>=3)
	    	
	    		ans=false;
	    		break;
	    	
	    
		if(ans)printf("<%s> is acceptable.\\n",kkke);
		else printf("<%s> is not acceptable.\\n",kkke);
	
	return 0;


以上是关于1039的主要内容,如果未能解决你的问题,请参考以下文章

http://acm.hdu.edu.cn/showproblem.php?pid=1039(水~)

德语发音教程:元音和辅音

C ++从文本文件中计算元音辅音

以元音、辅音开头的单词的读数

我的辅音/元音替换有啥错误?

如何检查Java中的句子中有多少个辅音和元音?