1104. Sum of Number Segments (20)数学题——PAT (Advanced Level) Practise
Posted 闲云阁
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1104. Sum of Number Segments (20)数学题——PAT (Advanced Level) Practise相关的知识,希望对你有一定的参考价值。
题目信息
1104. Sum of Number Segments (20)
时间限制200 ms
内存限制65536 kB
代码长度限制16000 B
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence 0.1, 0.2, 0.3, 0.4, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).
Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10^5. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.
Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.
Sample Input:
4
0.1 0.2 0.3 0.4
Sample Output:
5.00
解题思路
直接看代码吧,,不想多说,
AC代码
#include <cstdio>
int main()
int n;
long long st = 0;
double s = 0, v;
scanf("%d", &n);
for (int i = 0; i < n; ++i)
scanf("%lf", &v);
st += n - i - i;
s += v * st;
printf("%.2f\\n", s);
return 0;
以上是关于1104. Sum of Number Segments (20)数学题——PAT (Advanced Level) Practise的主要内容,如果未能解决你的问题,请参考以下文章
1104 Sum of Number Segments (20)
1104 Sum of Number Segments (20分)(long double)
1104 Sum of Number Segments (20分)