HDU 2955 Robberies && LightOJ 1079 Just another Robbery

Posted Calm微笑

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 2955 Robberies && LightOJ 1079 Just another Robbery相关的知识,希望对你有一定的参考价值。

Robberies

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 2
Problem Description The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.  
Input The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .  
Output For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. Notes and Constraints 0 < T <= 100 0.0 <= P <= 1.0 0 < N <= 100 0 < Mj <= 100 0.0 <= Pj <= 1.0 A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.  
Sample Input
  
   3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
  
 
Sample Output
  
   2
4
6
  
 
Source IDI Open 2009  题意:有N家银行,每个银行有一定的金额,和被抓的最大概率,给出robb被抓的最大概率,求不被抓的情况下,能抢到最多的钱数 如果直接考虑比较麻烦,可以取相反面,求安全概率;
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()

	int vi[110],sum;
	int i,j,m,n,t;
	double p,a,pi[10001],dp[10001];
	scanf("%d",&t);
	while(t--)
	
		scanf("%lf%d",&p,&n);
		p=1-p;
		sum=0;
		for(i=0;i<n;i++)
		
			scanf("%d%lf",&vi[i],&pi[i]);
			pi[i]=1-pi[i];
			sum+=vi[i];
		
	    memset(dp,0,sizeof(dp));
	    dp[0]=1;//不抢钱肯定安全 
	    for(i=0;i<n;i++)
	    for(j=sum;j>=vi[i];j--)
	    dp[j]=max(dp[j],dp[j-vi[i]]*pi[i]);//用乘,仔细想一下你就知道为什么了 
	    for(i=sum;i>=0;i--)
	    
	    	if(dp[i]-p>0.000000001)
	    	
	    		printf("%d\\n",i);
	    		break;
			
		
	
	return 0;
  


以上是关于HDU 2955 Robberies && LightOJ 1079 Just another Robbery的主要内容,如果未能解决你的问题,请参考以下文章

HDU-2955Robberies

HDU 2955 Robberies

HDU 2955 Robberies(DP)

HDU 2955 Robberies

hdu2955 Robberies (01背包)

HDU——2955Robberies