Codeforces 933 A. A Twisty Movement (dp)
Posted 小坏蛋_千千
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Codeforces 933 A. A Twisty Movement (dp)相关的知识,希望对你有一定的参考价值。
Description
A dragon symbolizes wisdom, power and wealth. On Lunar New Year’s Day, people model a dragon with bamboo strips and clothes, raise them with rods, and hold the rods high and low to resemble a flying dragon.
A performer holding the rod low is represented by a 1, while one holding it high is represented by a 2. Thus, the line of performers can be represented by a sequence a1, a2, ..., an a 1 , a 2 , . . . , a n .
Little Tommy is among them. He would like to choose an interval [l, r] (1 ≤ l ≤ r ≤ n) [ l , r ] ( 1 ≤ l ≤ r ≤ n ) , then reverse al, al + 1, ..., ar a l , a l + 1 , . . . , a r so that the length of the longest non-decreasing subsequence of the new sequence is maximum.
A non-decreasing subsequence is a sequence of indices p1, p2, ..., pk p 1 , p 2 , . . . , p k , such that p1 < p2 < ... < pk p 1 < p 2 < . . . < p k and ap1 ≤ ap2 ≤ ... ≤ apk a p 1 ≤ a p 2 ≤ . . . ≤ a p k . The length of the subsequence is k k .
Input
The first line contains an integer , denoting the length of the original sequence.
The second line contains n n space-separated integers, describing the original sequence .
Output
Print a single integer, which means the maximum possible length of the longest non-decreasing subsequence of the new sequence.
Examples input
4
1 2 1 2
Examples output
4
题意
在一个只包含 1,2 1 , 2 的序列中,翻转其中任意一个区间,求此时最大的 LIS 。
思路
正着倒着预处理出每一段的 LIS,分别记为 L[i][j],R[i][j] L [ i ] [ j ] , R [ i ] [ j ]
然后开始枚举,翻转一个区间相当于减去这段区间的贡献,然后加上其翻转以后的
此时 LIS 为 L[0][n−1]−L[i][j]+R[i][j] L [ 0 ] [ n − 1 ] − L [ i ] [ j ] + R [ i ] [ j ]
AC 代码
#include<bits/stdc++.h>
#define IO ios::sync_with_stdio(false);\\
cin.tie(0);\\
cout.tie(0);
using namespace std;
typedef __int64 LL;
const int maxn = 2e3+10;
int n;
int a[maxn];
int L[maxn][maxn],R[maxn][maxn];
int main()
IO;
cin>>n;
for(int i=0; i<n; i++)
cin>>a[i];
for(int i=0; i<n; i++)
int dp1 = 0, dp2 = 0;
for(int j=i; j<n; j++)
if(a[j]==1)
++dp1;
else
dp2 = max(dp1,dp2) + 1;
L[i][j] = max(dp1,dp2);
dp1 = dp2 = 0;
for(int j=i; j<n; j++)
if(a[j]==2)
++dp1;
else
dp2 = max(dp1,dp2) + 1;
R[i][j] = max(dp1,dp2);
int ans = 0;
for(int i=0; i<n; i++)
for(int j=i; j<n; j++)
ans = max(ans,L[0][n-1] - L[i][j] + R[i][j]);
cout<<ans<<endl;
return 0;
以上是关于Codeforces 933 A. A Twisty Movement (dp)的主要内容,如果未能解决你的问题,请参考以下文章
Codeforces 933 C. A Colourful Prospect (平面图,欧拉公式)
[Codeforces 933A]A Twisty Movement
[Codeforces 933B]A Determined Cleanup