UVA11176 Winning Streak概率

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA11176 Winning Streak概率相关的知识,希望对你有一定的参考价值。

“You can run on for a long time,
sooner or later God’ll cut you down.”
— Traditional folk song

Mikael likes to gamble, and as you know, you can place bets on almost anything these days. A particular thing that has recently caught Mikael’s interest is the length of the longest winning streak of a team during a season (i.e. the highest number of consecutive games won). In order to be able to make smarter bets, Mikael has asked you to write a program to help him compute the expected value of the longest winning streak of his favourite teams.
 In general, the probability that a team wins a game depends on a lot of different factors, such as whether they’re the home team, whether some key player is injured, and so on. For the first prototype of the program, however, we simplify this, and assume that all games have the same fixed probability p of being won, and that the result of a game does not affect the win probability for subsequent games.
 The expected value of the longest streak is the average of the longest streak in all possible outcomes of all games in a season, weighted by their probability. For instance, assume that the season consists of only three games, and that p = 0.4. There are eight different outcomes, which we can represent by a string of ‘W’😒 and ‘L’😒, indicating which games were won and which games were lost (for example, ‘WLW’ indicates that the team won the first and the third game, but lost the second). The possible results of the season are:

Result LLL LLW LWL LWW WLL WLW WWL WWW
Probability 0.216 0.144 0.144 0.096 0.144 0.096 0.096 0.064
Streak 0 1 1 2 1 1 2 3

In this case, the expected length of the longest winning streak becomes
   0.216 · 0 + 0.144 · 1 + 0.144 · 1 + 0.096 · 2 + 0.144 · 1 + 0.096 · 1 + 0.096 · 2 + 0.064 · 3 = 1.104
Input
Several test cases (at most 40), each containing an integer 1 ≤ n ≤ 500 giving the number of games in
a season, and a floating point number 0 ≤ p ≤ 1, the win probability. Input is terminated by a case
where n = 0, which should not be processed.
Output
For each test case, give the expected length of the longest winning streak. The answer should be given as a floating point number with an absolute error of at most 10−4
Sample Input
3 0.4
10 0.75
0 0.5
Sample Output
1.104000
5.068090.

问题链接UVA11176 Winning Streak
问题简述:(略)
问题分析:概率计算问题,不解释。解题代码来自仙客传奇团队。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA11176 Winning Streak */

#include <iostream>
#include <cstdio>

using namespace std;

const int N = 500 + 2;
double dp[N][N], pp[N], p;
int n;

int main()

    while(~scanf("%d%lf", &n, &p) && n) 
        pp[0] = 1;
        for (int i = 0; i <= n; i++)
            pp[i + 1] = pp[i] * p, dp[0][i]=1;

        for (int i = 1; i <= n; i++)
            for (int j = 0; j <= n; j++) 
                dp[i][j] = dp[i - 1][j];

                if (i == j + 1)
                    dp[i][j] -= pp[j + 1];
                else if (i > j + 1)
                    dp[i][j] -= dp[i - 1 - (j + 1)][j] * (1 - p) * pp[j + 1];
            

        double ans=0;
        for (int i = 1; i <= n; i++)
            ans += (dp[n][i] - dp[n][i - 1]) * i;

        printf("%.6f\\n", ans);
    

    return 0;

以上是关于UVA11176 Winning Streak概率的主要内容,如果未能解决你的问题,请参考以下文章

UVA11491-Erasing ans Winning(贪心)

UVa 11491 - Erasing and Winning

uva11491 Erasing and Winning

习题 8-4 UVA - 11491Erasing and Winning

UVa 11491 Erasing and Winning 题解

UVa 11181 条件概率