Kattis-Autori
Posted 做一个AC梦
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Kattis-Autori相关的知识,希望对你有一定的参考价值。
题目所述基本内容
Great scientific discoveries are often named by the last names of scientists that made them. For example, the most popular asymmetric cryptography system, RSA was discovered by Rivest, Shamir and Adleman. Another notable example is the Knuth-Morris-Pratt algorithm, named by Knuth, Morris and Pratt.
Scientific papers reference earlier works a lot and it’s not uncommon for one document to use two different naming conventions: the short variation (e.g. KMP) using only the first letters of authors last names and the long variation (e.g. Knuth-Morris-Pratt) using complete last names separated by hyphens.
We find mixing two conventions in one paper to be aesthetically unpleasing and would like you to write a program that will transform long variations into short.
输入输出样例
Input
The first and only line of input will contain at most 100 characters, uppercase and lowercase letters of the English alphabet and hyphen (‘-’ ASCII 45). The first character will always be an uppercase letter. Hyphens will always be followed by an uppercase letter. All other characters will be lowercase letters.
Output
The first and only line of output should contain the appropriate short variation.
Sample Input 1 | Sample Output 1 |
---|---|
Knuth-Morris-Pratt
| KMP
|
Sample Input 2 | Sample Output 2 |
---|---|
Mirko-Slavko
| MS
|
Sample Input 3 | Sample Output 3 |
---|---|
Pasko-Patak
| PP
|
代码
#include<iostream>
#include<string>
#include<vector>
using namespace std;
int main()
vector<char>result;
string str;
cin >> str;
result.push_back(str[0]);
for (int i = 1; i < str.size(); i++)
if (str[i]=='-')
result.push_back(str[i + 1]);
for (int i = 0; i < result.size(); i++)
cout << result[i];
return 0;
结束语
以上是关于Kattis-Autori的主要内容,如果未能解决你的问题,请参考以下文章