dfs全排列
Posted 桂林分晏
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了dfs全排列相关的知识,希望对你有一定的参考价值。
给定一个整数 n,将数字 1∼n 排成一排,将会有很多种排列方法。
现在,请你按照字典序将所有的排列方法输出。
输入格式
共一行,包含一个整数 n。
输出格式
按字典序输出所有排列方案,每个方案占一行。
数据范围
1≤n≤7
输入样例:
3
输出样例:
1 2 3
1 3 2
2 1 3
2 3 1
3 1 2
3 2 1
#include<iostream>
using namespace std;
const int N=10;
int n;
int path[N];
bool st[N];
void dfs(int u)
if(u==n)
for(int i=0;i<n;i++) printf("&d ",path[i]);
puts("");
return ;
for(int i=1;i<=n;i++)
if(!st[i])
path[u]=i;
st[i]=true;
dfs(u+1);
st[i]=false;
int main()
cin>>n;
dfs(0);
return 0;
以上是关于dfs全排列的主要内容,如果未能解决你的问题,请参考以下文章