ST750LMO 22 HN-750mBB SCSI Disk Device可以更换为固态硬盘吗?

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ST750LMO 22 HN-750mBB SCSI Disk Device可以更换为固态硬盘吗?相关的知识,希望对你有一定的参考价值。

完全可以,自己查开电脑后盖查看一下硬盘的尺寸大小及接口,或是拆下来,买一样尺寸及接口的固态硬盘换上即可,只是安装系统时注意硬盘格式,是ATA还是SATA,更换固态硬盘确实可以提高系统的运行速度,建议更换。 参考技术A 这个可以更换成为SSD的。 参考技术B

这是希捷320G的机械硬盘,不是固态硬盘。

CD(二分)

Problem Description

Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.

Input

The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.

Output

For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.

Sample Input

3 3
1
2
3
1
2
4
0 0

Sample Output

 2

虽然二分的思想小学就接触到到了,但是没想到查找居然这么快(emmm)

下面是自己脑补的算法,卡时间过去了,之前卡了十几次

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<vector>
using namespace std;
vector<long long> a;
vector<long long>::iterator i,j;
int main()
{
    int n,m;
    long long z;
    while(scanf("%d%d",&n,&m),n,m)
    {
        a.clear();
        int M=0;
        while(n--)
        {
            scanf("%I64d",&z);
            a.push_back(z);
        }
        while(m--)
        {
            scanf("%d",&z);
            a.push_back(z);
        }
        sort(a.begin(),a.end());
        i=a.begin();
        j=i++;
        for(;i!=a.end();i++,j++)
        {
            if(*i==*j) M++;
        }
        printf("%d\n",M);
    }
}

下面是二分的算法

#include<stdio.h>
int a[1000001];
int main()
{
    int n,m,f,l,i,mid,z,M;
    while(scanf("%d%d",&n,&m),n,m)
    {
        M=0;
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        while(m--)
        {
            scanf("%d",&z);
            f=0;
            l=n-1;
            while(1)
            {
                mid=(f+l)/2;
                if(z>a[mid]) f=mid+1;
                else if(z<a[mid]) l=mid-1;
                else
                {
                    M++;
                    break;
                }
                if(f>l) break;
            }
        }
        printf("%d\n",M);
    }
}

 

以上是关于ST750LMO 22 HN-750mBB SCSI Disk Device可以更换为固态硬盘吗?的主要内容,如果未能解决你的问题,请参考以下文章

ST:(homework 3)Some problems about Graph Coverage

软件测试homework 3

宝马750li故障码大全

SCS Characteristics

如果替代已在 scs.ttest_ind() 中编码为上 1 尾测试,我是不是需要将 p 值除以 2?

The Announcement of the SCS Mesoscale Processes Workshop