HDU 5974 A Simple Math Problem(数学解方程)——2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

Posted ITAK

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5974 A Simple Math Problem(数学解方程)——2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)相关的知识,希望对你有一定的参考价值。

传送门

A Simple Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 262    Accepted Submission(s): 120


Problem Description

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b
 
Input Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.  
Output For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).  
Sample Input
  
   6 8 
   
798 10780
 
Sample Output
  
   No Solution 
   
308 490
 

题目大意:

给了两个式子, x+y=aLCM(x,y)=b 输出的是 x,y ,如果不存在输出 No Solution

解题思路:

首先 LCM(x,y) = xyGCD(x,y) = b 又因为 GCD(x,y) = GCD(a,b) 那么现在这个 tmp = GCD(x,y) 就是常数了,那么就变成了 xytmp = b ,又因为 x+y = a 那么就可以得到 x(ax) = btmp 然后转化为 一元二次方程,求最优解。题目保证的是输出的 (x,y),xy

My Code

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
LL GCD(LL a, LL b)
    if(b == 0)
        return a;
    return GCD(b, a%b);

int main()

    LL a, b;
    while(~scanf("%lld%lld",&a,&b))
        LL tmp = GCD(a, b);
        b *= tmp;
        tmp = a*a - 4*b;
        if(tmp < 0)
            puts("No Solution");
        else
            if((LL)sqrt(tmp)*(LL)sqrt(tmp)!=tmp)
                puts("No Solution");
            else
                tmp = (LL)sqrt(tmp);
                LL ta1 = (a-tmp)/2, ta2 = a-ta1;
                LL tb1 = (a+tmp)/2, tb2 = a-tb1;
                if((a+tmp) & 1)
                    if((a-tmp) & 1)
                        puts("No Solution");
                    else
                        printf("%lld %lld\\n",min(ta1, ta2),max(ta1,ta2));
                
                else
                    if((a-tmp) & 1)
                        if(min(tb1,tb2) < 0)
                            puts("No Solution");
                        else
                            printf("%lld %lld\\n",min(tb1, tb2),max(tb1,tb2));
                    
                    else
                        if(min(tb1,tb2) < 0)
                            printf("%lld %lld\\n",min(ta1, ta2),max(ta1,ta2));
                        else
                            if(min(ta1,ta2) < min(tb1,tb2))
                                printf("%lld %lld\\n",min(ta1, ta2),max(ta1,ta2));
                            else
                                printf("%lld %lld\\n",min(tb1, tb2),max(tb1,tb2));
                        
                    
                
            
        
    
    return 0;

以上是关于HDU 5974 A Simple Math Problem(数学解方程)——2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)的主要内容,如果未能解决你的问题,请参考以下文章

HDU - 5974 A Simple Math Problem (数论 GCD)

hdu 5974 A Simple Math Problem(数学题)

HDU 5974 A Simple Math Problem 数学题

HDU5974 A Simple Math Problem---数论--转化解方程

HDU 5974 A Simple Math Problem ——(数论,大连区域赛)

HDU 5974 A Simple Math Problem(数学解方程)——2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)