1101. Quick Sort (25)快排——PAT (Advanced Level) Practise

Posted 闲云阁

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1101. Quick Sort (25)快排——PAT (Advanced Level) Practise相关的知识,希望对你有一定的参考价值。

题目信息

1101. Quick Sort (25)

时间限制200 ms
内存限制65536 kB
代码长度限制16000 B
There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 10^5). Then the next line contains N distinct positive integers no larger than 10^9. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5

解题思路

排序

AC代码

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
int n, mx[100005], rmn, a[100005];
int main()

    scanf("%d", &n);
    mx[0] = 0;
    rmn = 0x7fffffff;
    for (int i = 1; i <= n; ++i)
        scanf("%d", a+i);
        mx[i] = max(mx[i-1], a[i]);
    
    vector<int> v;
    for (int i = n; i >= 1; --i)
        if (a[i] >= mx[i-1] && a[i] <= rmn)
            v.push_back(a[i]);
        
        rmn = min(rmn, a[i]);
    

    printf("%d\\n", v.size());
    sort(v.begin(), v.end());
    if (v.size() > 0) 
        printf("%d", v[0]);
    
    for (int i = 1; i < v.size(); ++i)
        printf(" %d", v[i]);
    
    printf("\\n");
    return 0;

以上是关于1101. Quick Sort (25)快排——PAT (Advanced Level) Practise的主要内容,如果未能解决你的问题,请参考以下文章

1101. Quick Sort (25)快排——PAT (Advanced Level) Practise

1101 Quick Sort (25 分)难度: 一般 / 知识点: 快排

1101. Quick Sort (25)

1101 Quick Sort (25 分)

1101 Quick Sort (25 分)递推

1101 Quick Sort (25 分) st表