Problem H
Posted tansanity
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Problem H相关的知识,希望对你有一定的参考价值。
Problem Description In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.<br><br>Input The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.<br>The last test case is followed by a line containing two zeros, which means the end of the input.<br>
Output Output the sum of the value of the edges of the maximum pesudoforest.<br>
Sample Input
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
Sample Output
3 5
简单题意: 求出一个图的最大连通子图,连通分量最多只有一个环。现在需要编写一个程序,求出边的权值最大。在输入中给出顶点的个数、边的个数。 解题思路形成过程: 很典型的采用并查集处理回路的问题。和之前的题目很类似,但是还要判断是否有环,并且考虑三种合并并查集的情况。 感想: 题目做的越多,经验就会愈加丰富。 AC代码: #include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int visit[10005];
int set[10005];
struct node
int s;
int e;
int len;
a[100005];
int cmp(node a,node b)
return a.len>b.len;
int find(int x)
int r=x;
while(r!=set[r])
r=set[r];
int i=x;
while(i!=r)
int j=set[i];
set[i]=r;
i=j;
return r;
int main()
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
memset(a,0,sizeof(a));
int ans=0;
if(n==0&&m==0)
break;
for(int i=0;i<=n;i++)
set[i]=i;
visit[i]=0;
for(int i=1;i<=m;i++)
scanf("%d%d%d",&a[i].s,&a[i].e,&a[i].len);
sort(a+1,a+m+1,cmp);
for(int i=1;i<=m;i++)
int fx=find(a[i].s);
int fy=find(a[i].e);
if(fx==fy)
if(visit[fx]==1)
continue;
visit[fx]=1;
else
if(visit[fx]==1&&visit[fy]==1)
continue;
else if(visit[fx]==0)
set[fx]=fy;
else
set[fy]=fx;
ans+=a[i].len;
printf("%d\\n",ans);
return 0;
以上是关于Problem H的主要内容,如果未能解决你的问题,请参考以下文章
POJ 1637 Sightseeing tour(混合图欧拉回路+最大流)