AcWing 1762. 牛的洗牌

Posted 霜序0.2℃

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了AcWing 1762. 牛的洗牌相关的知识,希望对你有一定的参考价值。

题目

农夫约翰坚信快乐的奶牛会产出更多的牛奶,因此他在谷仓中安装了一个巨大的迪斯科球,并计划教他的奶牛跳舞!

在查阅了一些牛的流行舞蹈后,约翰决定教他的奶牛“洗牌舞”。

洗牌舞是由他的 NN 只奶牛按一定顺序排成一行,然后连续执行三次“洗牌”,每次“洗牌”都可能会使奶牛重新排序。

为了让奶牛们更容易找到自己所处的位置,约翰用数字 1∼N1∼N 对一行中奶牛所在的位置进行了标记,一行中第一头奶牛处于位置 11,第二头奶牛处于位置 22,以此类推,直到位置 NN。

每次“洗牌”用 NN 个数字 a1,a2,…,aNa1,a2,…,aN 来描述,处于位置 ii 的奶牛在一次“洗牌”过后,需要移动至位置 aiai(因此,每个 aiai 在 1…N1…N 范围内)。

幸运的是,所有 aiai 都是互不相同的,因此,不会存在多头奶牛在洗牌结束后移动到同一个位置的情况。

约翰的每头奶牛都有一个属于自己的唯一 77 位整数 IDID (不含前导 00)。

给定你三轮“洗牌”过后的奶牛排列顺序,请你求出奶牛们的初始排列顺序。

输入格式

第一行包含整数 NN。

第二行包含 NN 个整数,表示 a1,a2,…,aNa1,a2,…,aN。

第三行包含了 NN 头奶牛三轮“洗牌”过后的排列顺序,每头奶牛都用其 IDID 指代。

输出格式

共 NN 行,按照 NN 头奶牛的初始排列顺序,每行输出一头奶牛的 IDID。

数据范围

1≤N≤1001≤N≤100,
1≤ai≤N1≤ai≤N

输入样例:

5
1 3 4 5 2
1234567 2222222 3333333 4444444 5555555

输出样例:

1234567
5555555
2222222
3333333
4444444

解释和代码

简单模拟

主要是在数组中找下标这个地方,一般人可能是套三个循环,但是实际上可以构造一个新数组映射,嵌套即可

#include <bits/stdc++.h>
#define pb          push_back
#define ppb         pop_back
#define lbnd        lower_bound
#define ubnd        upper_bound
#define endl        '\\n'
#define all(a)      (a).begin(),(a).end()
#define what_is(x)  cerr << #x << " is " << x << endl;
#define ini(a)      memset(a,0,sizeof(a))
#define case        ll T;read(T);for(ll Q=1;Q<=T;Q++)
#define lowbit(x)   x&(-x)
#define pr          printf
#define sc          scanf
#define TIE \\
    cin.tie(0);cout.tie(0);\\
    ios::sync_with_stdio(false);

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const double PI    = acos(-1.0);
const int    INF   = 0x3f3f3f3f;
const ll     LLINF = 0x3f3f3f3f3f3f3f3f;
const int    maxn  = 999;
const ll     N     = 5;

int arr[maxn];
int mapping[maxn];
int id[maxn];
int ans[maxn];

void solve()
	int n;
	cin>>n;
	for (int i=1; i<=n; i++) 
		cin>>arr[i];
		mapping[arr[i]] = i;
	
	for (int i=1; i<=n; i++) cin>>id[i];
	for (int i=1; i<=n; i++) 
		ans[mapping[mapping[mapping[i]]]] = id[i];
	
	for (int i=1; i<=n; i++) cout<<ans[i]<<endl;


int main()

//	TIE;

	solve();
//    casesolve();
//    casecout<<"Case "<<Q<<":"<<endl;solve();

以上是关于AcWing 1762. 牛的洗牌的主要内容,如果未能解决你的问题,请参考以下文章

acwing 1776 牛的基因组学

算法刷题AcWing 102. 最佳牛围栏——二分

102. 最佳牛围栏(二分)

102. 最佳牛围栏(二分)

Til the Cows Come Home

AcWing 1776. 牛的基因组学(STL+枚举)