POJ P3311状压DPHie with the Pie

Posted SSL_ZZL

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ P3311状压DPHie with the Pie相关的知识,希望对你有一定的参考价值。

Hie with the Pie

POJ P3311 Hie with the Pie


题目

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

解题思路

不管三七二十一,先求个最短路,n≤10用Floyd就可以了
设 f[i][j] ,i 为所有点选没选(1/0)的状态,j 为最后走的一个点
转移就是很传统的状态转移,详见程序


Code

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

const int Inf = 0x7f7f7f7f;
int n, ans, a[30][30], f[1 << 15][30];

int main() 
	scanf("%d", &n);
	while(n) 
		memset(a, 0x3f, sizeof(a));
		for(int i = 0; i <= n; i ++)
			for(int j = 0; j <= n; j ++)
				scanf("%d", &a[i][j]);
		for(int k = 0; k <= n; k ++) 
			for(int i = 0; i <= n; i ++)
				for(int j = 0; j <= n; j ++)
					if(i != j && j != k && k != i)
						a[i][j] = min(a[i][j], a[i][k] + a[k][j]);  //最短路
		memset(f, 0x3f, sizeof(f));
		for(int i = 1; i <= n; i ++)
			f[1 << (i - 1)][i] = a[0][i];  //初始化从 0 走出来
		for(int i = 0; i < (1 << n); i ++) 
			for(int j = 1; j <= n; j ++) 
				if(!(i & (1 << (j - 1)))) continue;  // i 为当前状态,走过 j 和 k
				for(int k = 1; k <= n; k ++) 
					if(j == k) continue;
					if(!(i & (1 << (k - 1)))) continue;
					int s = i ^ (1 << (k - 1));  //s 是上一步的状态,最后一步是 j
					f[i][k] = min(f[i][k], f[s][j] + a[j][k]);
				
			
		
		ans = Inf;
		for(int i = 1; i <= n; i ++)
			ans = min(ans, f[(1 << n) - 1][i] + a[i][0]);  //注意最后还要走回0
		printf("%d\\n", ans);
		
		scanf("%d", &n);
	

以上是关于POJ P3311状压DPHie with the Pie的主要内容,如果未能解决你的问题,请参考以下文章

POJ P3311状压DPHie with the Pie

Hie with the Pie(POJ 3311)状压DP

POJ 3311---Hie with the Pie(状压DP)

状压DP Poj3311 Hie with the Pie

poj 3311 Hie with the Pie 经过所有点(可重)的最短路径 状压dp

Hie with the Pie-状压DP