最大K乘积问题
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了最大K乘积问题相关的知识,希望对你有一定的参考价值。
①问题描述
设I 是一个n 位十进制整数。如果将I 划分为k 段,则可得到k 个整数。这k 个整数的乘积称为I 的一个k 乘积。
对于给定的I 、n和k,试设计一个算法,编程计算I 的最大k 乘积。
②编程任务
对于给定的I 、n和k,试设计一个算法,编程计算I 的最大k 乘积。
③样例
例如,十进制整数3456的最大3乘积为1020。
十进制整数3456划分成3段有以下3种情形:
3 × 4 × 56 = 672
3 × 45 × 6 = 810
34 × 5 × 6 = 1020
麻烦帮我写下详细算法,最好附加C++源代码,万分感激
使用递归算法,要注意的是在得到一个k乘积时置一个全局变量为真,以便返回上一级递归调用后,将temp存储的数字回溯到前一状态。
你可以考虑用树来实现,我这里用了vector来实现的
#include <iostream>
#include <vector>
#include <string.h>
using namespace std;
#define BUFFERSIZE 50
char num[BUFFERSIZE]=0;
vector<string> temp;
vector<string> result;
double KProduct=0;
bool getAKproduct=false;
void kproduct(char* s, int n,int k)
vector<string>::iterator p;
if(n>0 && k==1)//get a kproduct
getAKproduct=true;
temp.push_back(s);
double product=1;
for (p=temp.begin(); p!=temp.end(); p++)
product *= atoi((*p).c_str());
if(product > KProduct)
KProduct = product;
result.clear();
result=temp;
else
for(int i=1; i<=n-k+1; i++) //i 取第一个数的长度
if(getAKproduct)
int poplength=0;
for(p=temp.end()-1; poplength!=n; temp.pop_back(),p=temp.end()-1)
poplength += (*p).size();
getAKproduct=false;
char *tmp=new char[BUFFERSIZE];
memset(tmp,0,BUFFERSIZE);
for(int j=0; j<i; j++)
if (tmp[0]==0)
tmp[0]=*(s+j);
else
tmp[strlen(tmp)] = *(s+j);
temp.push_back(tmp);
kproduct(s+i,n-i,k-1);
void main()
int k=0,n=0;
cout<<"input num and K:\n";
cin>>num>>k;
if (num[0]=='0')
cout<<"Be sure a number should begin with non 0\n";
return;
n = strlen(num);
if (n < k)
cout<<num<<" does not have a "<<k<<" product!";
return;
if(n > BUFFERSIZE)
cout<<"Buffer overload,size="<<BUFFERSIZE<<endl;
return;
kproduct(num,n,k);
cout<<num<<"'s max kproduct is ";
for(vector<string>::iterator p=result.begin(); p!=result.end(); p++)
cout<<(*p).c_str();
if (p==result.end()-1)
cout<<" = ";
else
cout<<"*";
cout<<KProduct<<endl;
参考技术A #include<stdio.h>
main()
int a,b1,b,c1,c,d1,d,m,k1,k2,k3,max,n1,n2,n3;
do
printf("please input number:");
scanf("%d",&m);
if(m>1000&&m<9999) break;
while(1);
a=m/1000;
b1=m%1000;
b=b1/100;
c1=b1%100;
c=c1/10;
d=c1%10;
k1=a*10+b;
n1=k1*c*d;
k2=b*10+c;
n2=a*k2*d;
k3=c*10+d;
n3=a*b*k3;
max=n1;
if(max<n2) max=n2;
if(max<n3) max=n3;
if(max==n1) printf("%d*%d*%d=%d\n",k1,c,d,n1);
if(max==n2) printf("%d*%d*%d=%d\n",k1,c,d,n2);
if(max==n3) printf("%d*%d*%d=%d\n",k1,c,d,n3);
不好意思,只能弄个四位数的。
因为我构建不了一个随即数的字符串截取函数。 参考技术B #include<stdio.h>
main()
int a,b1,b,c1,c,d1,d,m,k1,k2,k3,max,n1,n2,n3;
do
printf("please input number:");
scanf("%d",&m);
if(m>1000&&m<9999) break;
while(1);
a=m/1000;
b1=m%1000;
b=b1/100;
c1=b1%100;
c=c1/10;
d=c1%10;
k1=a*10+b;
n1=k1*c*d;
k2=b*10+c;
n2=a*k2*d;
k3=c*10+d;
n3=a*b*k3;
max=n1;
if(max<n2) max=n2;
if(max<n3) max=n3;
if(max==n1) printf("%d*%d*%d=%d\n",k1,c,d,n1);
if(max==n2) printf("%d*%d*%d=%d\n",k1,c,d,n2);
if(max==n3) printf("%d*%d*%d=%d\n",k1,c,d,n3);
参考技术C 用回朔法本回答被提问者采纳
乘积最大
乘积最大
Description
问题描述: 今年是国际数学联盟确定的“2000——世界数学年”,又恰逢我国著名数学家华罗庚先生 诞辰90周年。在华罗庚先生的家乡江苏金坛,组织了一场别开生面的数学智力竞赛的活动,你的一个好朋友XZ也有幸得以参加。活动中,主持人给所有参加活动的选手出了这样一道题目:设有一个长度为N的数字串,要求选手使用K个乘号将它分成K+1个部分,找出一种分法,使得这K+1个部分的乘积能够为最大。同时,为了帮助选手能够正确理解题意,主持人还举了如下的一个例子:有一个数字串:312, 当N=3,K=1时会有以下两种分法:
1) 3*12=36
2) 31*2=62
这时,符合题目要求的结果是:31*2=62 现在,请你帮助你的好朋友XZ设计一个程序,求得正确的答案。
Input
第一行共有2个自然数N,K(6≤N≤40,1≤K≤6)第二行是一个长度为N的数字串。
Output
输出所求得的最大乘积(一个自然数)。
Sample Input
4 2
1231
Sample Output
62
HINT
Source
#include <bits/stdc++.h>
using namespace std;
int n, k;
char s[100];
int a[100];
int f[41][7];
int num(int p, int q) {
int ans = 0;
for (int i = p; i <= q; i ++) {
ans = ans * 10 + a[i];
}
return ans;
}
int main() {
scanf("%d%d", &n, &k);
scanf("%s", s);
for (int i = 0; i < n; i ++) {
a[i + 1] = s[i] - '0';
}
for (int i = 1; i <= n; i ++) {
f[i][0] = num(1, i);
}
for (int i = 1; i <= n; i ++) {
for (int j = 1; j <= k; j ++) {
for (int t = 1; t <= i; t ++) {
int res = f[t - 1][j - 1] * num(t, i);
if (res > f[i][j]) {
f[i][j] = res;
}
}
}
}
cout << f[n][k] << endl;
return 0;
}
以上是关于最大K乘积问题的主要内容,如果未能解决你的问题,请参考以下文章