1038

Posted tookkke

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1038相关的知识,希望对你有一定的参考价值。

Biker's Trip Odometer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5303    Accepted Submission(s): 3539


Problem Description Most bicycle speedometers work by using a Hall Effect sensor fastened to the front fork of the bicycle. A magnet is attached to one of the spokes on the front wheel so that it will line up with the Hall Effect switch once per revolution of the wheel. The speedometer monitors the sensor to count wheel revolutions. If the diameter of the wheel is known, the distance traveled can be easily be calculated if you know how many revolutions the wheel has made. In addition, if the time it takes to complete the revolutions is known, the average speed can also be calculated. 
For this problem, you will write a program to determine the total distance traveled (in miles) and the average speed (in Miles Per Hour) given the wheel diameter, the number of revolutions and the total time of the trip. You can assume that the front wheel never leaves the ground, and there is no slipping or skidding.
 
Input Input consists of multiple datasets, one per line, of the form:

diameter revolutions time

The diameter is expressed in inches as a floating point value. The revolutions is an integer value. The time is expressed in seconds as a floating point value. Input ends when the value of revolutions is 0 (zero).
 
Output For each data set, print:

Trip #N: distance MPH

Of course N should be replaced by the data set number, distance by the total distance in miles (accurate to 2 decimal places) and MPH by the speed in miles per hour (accurate to 2 decimal places). Your program should not generate any output for the ending case when revolutions is 0.

Constants

For p use the value: 3.1415927.
There are 5280 feet in a mile.
There are 12 inches in a foot.
There are 60 minutes in an hour.
There are 60 seconds in a minute.
There are 201.168 meters in a furlong.
 
Sample Input
  
   26 1000 5
27.25 873234 3000
26 0 1000
  
 
Sample Output
  
   Trip #1: 1.29 928.20
Trip #2: 1179.86 1415.84
  
 



    初看题目有点复杂,主要是读题的问题,其实这道题非常简单,就是给定轮子的直径,转动圈数,时间,要求路程和速度,只需注意单位换算就行了

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;
/*
For p use the value: 3.1415927.
There are 5280 feet in a mile.
There are 12 inches in a foot.
There are 60 minutes in an hour.
There are 60 seconds in a minute.
There are 201.168 meters in a furlong.
*/
const double PI=3.1415927;

int main()

	freopen("input.txt","r",stdin);
	freopen("output.txt","w",stdout);
	double d,r,t,s,v;
	for(int i=1;scanf("%lf%lf%lf",&d,&r,&t),r;i++)
	
		s=PI*d*r/12.0/5280.0;
		v=s/t*3600.0;
		printf("Trip #%d: %.2lf %.2lf\\n",i,s,v);
	
	return 0;




以上是关于1038的主要内容,如果未能解决你的问题,请参考以下文章

CF 592D(Super M-虚树直径)

HDU 1038[Biker's Trip Odometer]简单计算

P4381 [IOI2008]Island

PAT Advanced Level 1038

PAT乙级1038

#1038 : 01背包