C语言中 toupper()和tolower()用法?请大神详述 谢谢!!!
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了C语言中 toupper()和tolower()用法?请大神详述 谢谢!!!相关的知识,希望对你有一定的参考价值。
1、tolower()函数。
inttolower(intc);
2、toupper()函数
inttoupper(intc);
例:
#include<stdio.h>
#include<ctype.h>
intmain(void)
charch='A';
ch=tolower(ch);
printf("ch=%c\\n",ch);
ch='b';
ch=toupper(ch);
printf("ch=%c\\n",ch);
return0;
扩展资料
在C++里tolower的使用
#include<iostream>
#include<string>
#include<cctype>
usingnamespacestd;
intmain()
stringstr="THISISASTRING";
for(inti=0;i<str.size();i++)
str[i]=tolower(str[i]);
cout<<str<<endl;
return0;
参考技术Atoupper()将字符转换为大写英文字母
char ch;ch = toupper('a'); // ch 就为 A
tolower()把字符转换成小写字母
char ch;ch = tolower('A'); // ch 就为 a本回答被提问者采纳 参考技术B char a = 'a';
char b = toupper(a); //b被赋值为'A'
tolower类似
字符串大小写互转(函数法)
- toupper函数
toupper是小写转大写函数,toupper函数原型为:
int toupper(int c)
if (c >= 'a' && c <= 'z')
return c + ('A' - 'a');
else
return c;
- tolower函数
tolower是大写转小写函数,tolower函数原型为:
int tolower(int c)
if (c >= 'A' && c <= 'Z')
return c + ('a' - 'A');
else
return c;
它们有一个共同的特点:只对英文字母进行修改
。
注意:这两个函数使用时都需要写头文件 #include <ctype.h>
,而且每次只能修改一个字符,所以,我们不能用这两个函数直接处理一串字符。
下面是一个实例的应用:
题目描述
输入一个长度不超过 100 且不包括空格的字符串。
要求一:将该字符串中的所有小写字母变成大写字母并输出。
要求二:将该字符串中的所有大写字母变成小写字母并输出。
输入样例
abcdeFGH
输出样例
ABCDEFGH
abcdefgh
下面是我的AC代码
#include <iostream>
#include <ctype.h>// toupper tolower
#include <cstring>
using namespace std;
int main()
char a[100];
int n, i;
cin >> a;
n = strlen(a);
for (i = 0; i < n; i++)
a[i] = toupper(a[i]);//小写转大写
cout << a << endl;
for (i = 0; i < n; i++)
a[i] = tolower(a[i]);//大写转小写字母(只能是对字母有效)
cout << a << endl;
return 0;
以上是关于C语言中 toupper()和tolower()用法?请大神详述 谢谢!!!的主要内容,如果未能解决你的问题,请参考以下文章
C#慎用ToLower和ToUpper,小心把你的系统给拖垮了
ccf 201409-3 字符串匹配(toupper,tolower)