HDU 1017 A Mathematical Curiosity (枚举水题)

Posted clnchanpin

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1017 A Mathematical Curiosity (枚举水题)相关的知识,希望对你有一定的参考价值。

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
1 10 1 20 3 30 4 0 0
 

Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
 
  WA点在于格式控制!!

!细致审题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
	int a,b,mod,n,m,t,number,ans;
	scanf("%d",&t);
	while(t--) {
		number=0;
		while(scanf("%d%d",&n,&m)!=EOF){
			if(n==0 && m==0) break;
			ans=0;
			for(a=1;a<n;a++) {
				for(b=a+1;b<n;b++) {
					if((a*a+b*b+m)%(a*b)==0) ans++;
				}
			}
			printf("Case %d: %d\n",++number,ans);
		}
		if(t) printf("\n");
	}
	return 0;
}

















以上是关于HDU 1017 A Mathematical Curiosity (枚举水题)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1017 A Mathematical Curiosity (数学)

HDU 1017 A Mathematical Curiosity (枚举水题)

HDU 1017 A Mathematical Curiosity

Hdu oj 1017 A Mathematical Curiosity

HDU 1017 A Mathematical Curiosity (输出格式,穷举)

HDU 1017 A Mathematical Curiosity看懂题意+穷举法