HDU - 4810 Wall Painting 二进制+组合数学+异或

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU - 4810 Wall Painting 二进制+组合数学+异或相关的知识,希望对你有一定的参考价值。


Wall Painting

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4372    Accepted Submission(s): 1476


 

Problem Description

Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.

When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with

 different plans.


For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.

Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?

You should tell Mr.Fang the answer from the first day to the n-th day.

 

 

Input

There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 103).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

 

 

Output

For each test case, output N integers in a line representing the answers(mod 106 +3) from the first day to the n-th day.

 

 

Sample Input


 


4 1 2 10 1

 

 

Sample Output


 


14 36 30 8

 

 

Source

​2013ACM/ICPC亚洲区南京站现场赛——题目重现​

 

 

Recommend

liuyiding

题意:给你n个数,分别求出n个数选取k个数异或的结果的和sum,1<=k<=n。

分析:暴力枚举肯定超时。

这里就需要一个思维转化二进制,

我们题目为例子:

1:  0001

2:  0010

10:1010

1:     0001

首先,我们知道异或的性质,只有奇数个1为1,这里他要求选k个数来异或,我们可以把n个数的对应的同列的选取出来k个异或,

(即上面按列异或,把每一列看作一个运算结果)我们发现只有选奇数个1对应的列才有值(值为1<<j  j为二进制位数),

所以,一开始文明要统计出来每一列的1的个数,i列选k个数来异或的话,选出奇数m个1,剩下k-m都选0,即C(num[i],m)*C(n-num[i],k-m)*1<<(i-1),按列累加起来就行。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
using namespace std;
#define ll long long
#define N 1005
const int mod=1e6+3;

int n;
int num[35];

ll C[N][N],ans[N];

void Initial()

int i,j;
for(i=0; i<N; ++i)

C[0][i] = 0;
C[i][0] = 1;

for(i=1; i<N; ++i)

for(j=1; j<N; ++j)
C[i][j] = (C[i-1][j] + C[i-1][j-1])%mod;


int main()

Initial();

while(scanf("%d",&n)!=-1)

memset(num,0,sizeof(num));
memset(ans,0,sizeof(ans));
int maxx=0;
for(int i=1;i<=n;i++)

ll x;
int cnt=1;
scanf("%lld",&x);
while(x)

if(x&1) num[cnt]++;
x=x>>1;
cnt++;

maxx=max(maxx,cnt);


for(int i=1;i<=n;i++)

for(int j=1;j<maxx;j++)


ll val=(1<<(j-1));
//cout<<j<<" "<<val<<endl;
for(int k=1;k<=num[j]&&i>=k;k+=2)

ans[i]=(ans[i]+C[num[j]][k]*C[n-num[j]][i-k]%mod*val%mod)%mod;



for(int i=1;i<n;i++)
printf("%lld ",ans[i]);
printf("%lld\\n",ans[n]);


return 0;

 

以上是关于HDU - 4810 Wall Painting 二进制+组合数学+异或的主要内容,如果未能解决你的问题,请参考以下文章

HDU 4810 Wall Painting (位操作-异或)

hdu-4810 Wall Painting 2013ACM/ICPC亚洲区南京站现场赛

XCPC真题:Bits Reverse | Empty Squares | Wall Painting

[Codefoeces398B]Painting The Wall(概率DP)

Rotational Painting(hdu 3685 凸包+多边形重心 模板题

Rotational Painting(hdu 3685 凸包+多边形重心 模板题