poj1007老是出现wrong answer!!!

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj1007老是出现wrong answer!!!相关的知识,希望对你有一定的参考价值。

#include<stdio.h>
struct DNA

char name[51];
int num;
dna[1001],t;
int main()

int i,j,m,n,k;
while (scanf ("%d %d",&n,&m)!=EOF)

for (i=0;i<m;i++)

scanf ("%s",dna[i].name);
dna[i].num=0;
for (j=0;j<n;j++)

for (k=j+1;k<n-1;k++)

if (dna[i].name[k]<dna[i].name[j])
dna[i].num=dna[i].num+1;



for(i=0;i<m;i++)

for(j=i+1;j<m;j++)

if(dna[i].num>=dna[j].num)

t=dna[i];
dna[i]=dna[j];
dna[j]=t;



for(i=0;i<m;i++)

for(j=0;j<n;j++)

if(dna[i].name[j]=='A'||dna[i].name[j]=='C'||dna[i].name[j]=='T'||dna[i].name[j]=='G')
continue;
else
break;

printf ("%s\n",dna[i].name);


return 0;

#include <iostream>
#include <cstring>
#include <cstdio>
struct type

    char k[51];
    long long st;
;
using namespace std;

int main()

    type dna[101];
    int m,n,maxn;
    long long sum=0;
    int a,b,c;
    cin>>m>>n;
    for(a=1;a<=n;a++)
      cin>>dna[a].k;
    for(a=1;a<=n;a++)
    
        sum=0;
        for (b=0;b<m-1;b++)
          for(c=b+1;c<=m-1;c++)
            if (dna[a].k[b]>dna[a].k[c])
              sum++;
        dna[a].st=sum;
    
    for(a=1;a<=n;a++)
    
        maxn=1;
        for(b=1;b<=n;b++)
          if (dna[maxn].st>dna[b].st)
            maxn=b;
        dna[maxn].st=1000000000;
        cout<<dna[maxn].k<<endl;
    
    return 0;

这是我的代码,你先看着= =我看看题,好久以前的了

这是单组数据测试,你读入1次n,m看看能不能AC

发现了,把冒泡排序的<=改成<,他要求稳定排序。

还有最后一段代码看不懂你在干什么,但是应该不影响,就是冒泡排序的问题

参考技术A wrong answer中文意思是答案错误。可能是需要什么密码的

hdu-3038 How Many Answers Are Wrong[并查集]

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)

Problem Description

TT and FF are ... friends. Uh... very very good friends -________-b
FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

技术分享图片

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF‘s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.
Boring~~Boring~~a very very boring game!!! TT doesn‘t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.
The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.
However, TT is a nice and lovely girl. She doesn‘t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.
What‘s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.
But there will be so many questions that poor FF can‘t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.
Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It‘s guaranteed that 0 < Ai <= Bi <= N.
You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1

Sample Output

1

题意:

每次给出一个区间,和这个区间的所有数的和,检查有一次给出区间的值和给出的值矛盾

思路:

可以用一个数组num记录每个位置到其根节点区间内所有的元素和。每次判断是否给出的两个位置是否在一个根节点上,也就是说是否可比。如果可比,检查这两个点之间的元素和和给出的是否一致。如果不一致,就将根节点跟新为最的那个,然后更新距离。

然后令$B_i$向后移动增加一个,解决距离在计算的时候的问题。

#include "cmath"
#include "cstring"
#include "algorithm"
#include "cstdio"
using namespace std;
const int maxn = 200000 + 100;
int N, M;
int par[maxn];
int num[maxn];
int ans;
int find_root(int x){
    if(x!=par[x]){
        int t = par[x];
        par[x] = find_root(par[x]);
        num[x] += num[t];
    }
    return par[x];
}
void unite(int x, int y, int z) {
    int fx = find_root(x);
    int fy = find_root(y);
    if (fx != fy) {
        num[fy] = z - num[y] + num[x];
        par[fy] = fx;
    }
    else {
        if (num[y] - num[x] != z) ans++;
    }
}
void init() {
    ans = 0;
    memset(num, 0, sizeof(num));
    for (int i = 0;i < maxn; i++) par[i]=i;
}
int main(int argc, char const *argv[]) {
    while (scanf("%d%d", &N, &M) != EOF) {
        init();
        for (int i = 0; i < M; i++) {
            int a, b, c;
            scanf("%d%d%d", &a, &b, &c);
            if (a < b) unite(a, b + 1, c);
            else unite(b, a + 1, c);
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

 

以上是关于poj1007老是出现wrong answer!!!的主要内容,如果未能解决你的问题,请参考以下文章

hdu 2023wrong answer!

HDU 3038 - How Many Answers Are Wrong

CF1130E Wrong Answer

hdu3038 How Many Answers Are Wrong

How Many Answers Are Wrong

hdu-3038 How Many Answers Are Wrong[并查集]