hdu 1046 Gridland

Posted 计算机科学家的世界

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1046 Gridland相关的知识,希望对你有一定的参考价值。

Problem Description For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the “easy” problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the “hard” ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point.

The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North–South or East–West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 × 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 × 3-Gridland, the shortest tour has length 6. 


 
Input The first line contains the number of scenarios.

For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.
 
Output The output for each scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.
 
Sample Input
  
   2
2 2
2 3
  
 
Sample Output
  
   Scenario #1:
4.00

Scenario #2:
6.00
  
 
Source Northwestern Europe 2001  


思路:m*n个点,显然至少要走m*n步,如果m,n中有一个是偶数(至少一个),则显然m*n的距离可以到,否则,至少要走一个对角线,而可以构造出仅走一个对角线的路线。(比较容易)。

代码如下:

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int main()
	int n;
	cin>>n;
	for(int i = 1; i <= n; ++i)
		int a, b;
		double z;
		cin>>a>>b;
		if(a % 2 == 0 || b % 2 == 0)
			z = a * b;
		else
			z = a * b - 1 + sqrt(2);
		
		printf("Scenario #%d:\\n", i);
		printf("%.2f\\n\\n", z);
	

结果:

Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
158227352015-12-11 22:28:01Accepted104631MS1768K394 BC++BossJue


以上是关于hdu 1046 Gridland的主要内容,如果未能解决你的问题,请参考以下文章

hdu1046

hdu 3473 (划分树)2

BZOJ 1046 1046: [HAOI2007]上升序列

ls1046aARM工控主板的介绍

导入数据库时​​出现错误 #1046

导入数据库时​​出现错误 #1046