HDU-ACM2017

Posted 夏小弥

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU-ACM2017相关的知识,希望对你有一定的参考价值。

字符串统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66180    Accepted Submission(s): 36213


Problem Description 对于给定的一个字符串,统计其中数字字符出现的次数。  
Input 输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。  
Output 对于每个测试实例,输出该串中数值的个数,每个输出占一行。  
Sample Input
  
   2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf
  
 
Sample Output
  
   6
9
  

import java.util.*;

class Main

    public static void main(String args[])
        Scanner input=new Scanner(System.in);
        int n=input.nextInt();
        while (n-->0)
        
            int count=0;
            int c=0;
            String str=input.next();
            for (int i=0;i<str.length() ;i++ )
            
                char ch=str.charAt(i);
                if (ch>='0'&&ch<='9')
                
                    count++;
                
            
            System.out.println(count);
        
    


以上是关于HDU-ACM2017的主要内容,如果未能解决你的问题,请参考以下文章

2017.04.13-2017.07.17

vs2017rc和vs2017啥意思

P3723 [AH2017/HNOI2017]礼物(FFT)

msvc2017 2015的区别

IntelliJ IDEA 2017新工具

VS2017创建winform中标题为啥不居中