Pick apples 第三届acm省赛

Posted 给大佬递女装

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Pick apples 第三届acm省赛相关的知识,希望对你有一定的参考价值。

Description

 

Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because she has never seen so many apples before. Each kind of apple has a size and a price to be sold. Now the little girl wants to gain more profits, but she does not know how. So she asks you for help, and tell she the most profits she can gain.

 

Input

In the first line there is an integer T (T <= 50), indicates the number of test cases.
In each case, there are four lines. In the first three lines, there are two integers S and P in each line, which indicates the size (1 <= S <= 100) and the price (1 <= P <= 10000) of this kind of apple.

In the fourth line there is an integer V,(1 <= V <= 100,000,000)indicates the volume of the girl‘s bag.

Output

For each case, first output the case number then follow the most profits she can gain.

Sample Input

1
1 1
2 1
3 1
6

Sample Output

Case 1: 6

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct N
{
    int s,p;
    double pri;
} node[4];
bool cmp(N a,N b)
{
    if(a.pri<b.pri)        return true;
    return false;
}
long long llmax(long long a,long long b)
{
    return a>b?a:b;
}
int main()
{
    int t;
    cin>>t;
    int c=1;
    while(t--)
    {
        for(int i=0;i<3;i++){
            cin>>node[i].s>>node[i].p;
            node[i].pri = 1.0*node[i].s/(1.0*node[i].p);
        }
        int V;
        cin>>V;
        sort(node,node+3,cmp);
        long long ans=0;
        for(int i=0; i<node[0].s; i++)
        {
            for(int j=0; j<node[0].s; j++)
            {
                long long temp=i*node[1].s+j*node[2].s;
                if(temp>V)
                    break;
                else
                {
                    long long v=V-temp;
                    ans=llmax(ans,v/node[0].s*node[0].p+i*node[1].p+j*node[2].p);
                }
            }
        }
        cout<<"Case "<<c++<<": "<<ans<<endl;
    }
    return 0;
}

 

以上是关于Pick apples 第三届acm省赛的主要内容,如果未能解决你的问题,请参考以下文章

记2016商大ACM省赛

河南省第十届ACM省赛赛后感想-想个屁啊!

Graph(2014辽宁ACM省赛)

2017年山东省ACM省赛总结

Pick apples(完全背包+贪心)

第十届山东省ACM省赛题解