PAT甲级1007
Posted wx630c98f24f6b8
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级1007相关的知识,希望对你有一定的参考价值。
1007. Maximum Subsequence Sum (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Given a sequence of K integers N1, N2, ..., NK . A continuous subsequence is defined to be Ni, Ni+1, ..., Nj where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence -2, 11, -4, 13, -5, -2 , its maximum subsequence is 11, -4, 13 with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10 -10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 10010;
int N[maxn];
int d[maxn];
int main()
int K;
scanf("%d", &K);
for (int i = 0; i < K; i++)
scanf("%d", &N[i]);
d[0] = N[0];//边界
for (int i = 1; i < K; i++)
d[i] = max(N[i], d[i - 1]+N[i]);//状态转移方程
int k=0;//由于是d[i]表示下标为i的数为尾的最大连续子序列的和,也就是说N[i]必须在其中
//那么d[K-1]不一定是最大的,需要对d[]进行遍历找最大的,并记录下标
for (int i = 0; i < K; i++)
if (d[i] > d[k])
k = i;
int sum = d[k];
int j = k;//j用来求最大子序列和的第一个数
if (sum != 0)//这个地方得注意下,若sum就等于0,j不需要自增
while (sum != 0)
sum -= N[j];
j--;
j++;
if (d[k] < 0)
printf("0 %d %d\\n", N[0], N[K-1]);
else
printf("%d %d %d\\n", d[k], N[j], N[k]);//注意题目说的是序列中的元素而不是下标
return 0;
以上是关于PAT甲级1007的主要内容,如果未能解决你的问题,请参考以下文章
PAT甲级 1007 Maximum Subsequence Sum
PAT甲级 1007 Maximum Subsequence Sum