PAT甲级1120
Posted wx630c98f24f6b8
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级1120相关的知识,希望对你有一定的参考价值。
1120. Friend Numbers (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend IDs among them. Note: a number is considered a friend of itself.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.
Output Specification:
For each case, print in the first line the number of different frind IDs among the given integers. Then in the second line, output the friend IDs in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.
Sample Input:
8 123 899 51 998 27 33 36 12
Sample Output:
4 3 6 9 26
#include<iostream>
#include<set>
#include<string>
#include<algorithm>
using namespace std;
int main()
int N;
cin >> N;
string s;
set<int> st;
for (int i = 0; i < N; i++)
cin >> s;
int sum = 0;
for (int j = 0; j < s.size(); j++)
sum += s[j] - 0;
st.insert(sum);
cout << st.size() << endl;
for (set<int>::iterator it = st.begin(); it != st.end(); it++)
if (it == st.begin())
cout << *it;
else
cout << " " << *it;
return 0;
以上是关于PAT甲级1120的主要内容,如果未能解决你的问题,请参考以下文章