PAT甲级1076

Posted wx630c98f24f6b8

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级1076相关的知识,希望对你有一定的参考价值。


1076. Forwards on Weibo (30)


时间限制



3000 ms



内存限制



65536 kB



代码长度限制



16000 B



判题程序



Standard



作者



CHEN, Yue


Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserIDs for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.


Sample Input:


7 3 3 2 3 4 0 2 5 6 2 3 1 2 3 4 1 4 1 5 2 2 6


Sample Output:


4 5




#include<cstdio>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 1010;
bool inq[maxn] = false ;
vector<int> G[maxn];
int N, L,M,uid,K,query;
int BFS(int start)

fill(inq, inq + maxn, false);
int potential = 0;
queue<int> Q;
Q.push(start);
inq[start] = true;
int level = 0;
int lastnode=start, newLastNode;
while (!Q.empty())

int f = Q.front();
Q.pop();
if (G[f].size())

for (int i = 0; i <G[f].size(); i++)

int t = G[f][i];
if (!inq[t])

Q.push(t);
inq[t] = true;
newLastNode = t;



if (level >= 1 && level <= L)//这个地方,我觉得题意有点问题,他说只计L层间接粉丝数
//但真正表达的意思是只计L层直接或间接粉丝数
potential++;

if (f == lastnode)

lastnode = newLastNode;
level++;


return potential;

int main()

scanf("%d %d", &N, &L);
for (int i = 1; i <=N; i++)

scanf("%d", &M);
for (int j = 0; j < M; j++)

scanf("%d", &uid);
G[uid].push_back(i);


scanf("%d", &K);
for (int i = 0; i < K; i++)

scanf("%d", &query);
printf("%d\\n", BFS(query));

return 0;


以上是关于PAT甲级1076的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲级--Mice and Rice (25)

PAT 甲级1010 Radix (25分)

PAT甲级--Kuchiguse (20)

PAT甲级第二题-- A+B for Polynomials

PAT甲级1134 Vertex Cover (25分)

PAT甲级1024 Palindromic Number (25 分)