PAT甲级1064

Posted wx630c98f24f6b8

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级1064相关的知识,希望对你有一定的参考价值。


1064. Complete Binary Search Tree (30)


时间限制



100 ms



内存限制



65536 kB



代码长度限制



16000 B



判题程序



Standard



作者



CHEN, Yue


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the nodes key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the nodes key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.


Sample Input:


10 1 2 3 4 5 6 7 8 9 0


Sample Output:


6 3 8 1 5 7 9 0 2 4




#include<cstdio>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
struct node

int data;
node*l, *r;
node():l(NULL),r(NULL)
;
void createCBT(node*&root,int N)

queue<node*> Q;
if (!root)

root = new node;
N--;
if (!N)
return;
Q.push(root);

while (!Q.empty())

node* t = Q.front();
Q.pop();
if (!t->l)

t->l = new node;
Q.push(t->l);
N--;
if (!N)
return;

if (!t->r)

t->r = new node;
Q.push(t->r);
N--;
if (!N)
return;



vector<int> v; int index = 0;
void inorder(node* &root)

if (!root)
return;
inorder(root->l);
root->data = v[index++];
inorder(root->r);

void levelorder(node*root)

queue<node*> Q;
if (root)

printf("%d", root->data);
Q.push(root);

while (!Q.empty())

node*f = Q.front();
Q.pop();
if (f->l)

printf(" %d", f->l->data);
Q.push(f->l);

if (f->r)

printf(" %d", f->r->data);
Q.push(f->r);



int main()

int N;
scanf("%d", &N);
node*root = NULL;
int t;
for (int i = 0; i <N; i++)

scanf("%d", &t);
v.push_back(t);

createCBT(root, N);//先造出未装填数据的完全二叉树
sort(v.begin(), v.end());//利用BST的中序遍历是递增序列
inorder(root);//对完全二叉树进行中序遍历并往其中填数据
levelorder(root);
return 0;


以上是关于PAT甲级1064的主要内容,如果未能解决你的问题,请参考以下文章

pat甲级75分在啥水平

pat甲级没做出来没有分吗

pat甲级60分啥水平

pat可以直接考甲级吗

pat甲级考试+pat1051+1056

PAT甲级——A1025 PAT Ranking