PAT甲级1106
Posted wx630c98f24f6b8
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级1106相关的知识,希望对你有一定的参考价值。
1106. Lowest Price in Supply Chain (25)
时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from ones supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.
Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their IDs are numbered from 0 to N-1, and the root suppliers ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
Ki ID[1] ID[2] ... ID[Ki]
where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the IDs of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.
Sample Input:
10 1.80 1.00 3 2 3 5 1 9 1 4 1 7 0 2 6 1 1 8 0 0 0
Sample Output:
1.8362 2
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int N;
double P, r;
const int maxn = 100000;
vector<int> children[maxn];
int minlevel = 1000000000;
void DFS(int root, int l)
if (!children[root].size())
minlevel = min(l, minlevel);
return;
for (int i = 0; i < children[root].size(); i++)
DFS(children[root][i], l + 1);
void DFS(int root, int l, int &count)
if (!children[root].size())
if (l == minlevel)count++;
return;
for (int i = 0; i < children[root].size(); i++)
DFS(children[root][i], l + 1, count);
int main()
scanf("%d%lf%lf", &N, &P, &r);
int t,child;
for (int i = 0; i < N; i++)
scanf("%d", &t);
for (int j = 0; j < t; j++)
scanf("%d", &child);
children[i].push_back(child);
DFS(0, 0);
int count = 0;
DFS(0, 0, count);
printf("%.4f %d", P*pow((1.0 + r / 100), minlevel), count);
return 0;
以上是关于PAT甲级1106的主要内容,如果未能解决你的问题,请参考以下文章