PAT甲级1044

Posted wx630c98f24f6b8

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级1044相关的知识,希望对你有一定的参考价值。


1044. Shopping in Mars (25)


时间限制



100 ms



内存限制



65536 kB



代码长度限制



16000 B



判题程序



Standard



作者



CHEN, Yue


Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.


Sample Input 1:


16 15 3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13


Sample Output 1:


1-5 4-6 7-8 11-11


Sample Input 2:


5 13 2 4 5 7 9


Sample Output 2:


2-4 4-5




#include<cstdio>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;

int main()

int N, M;
scanf("%d %d", &N, &M);
int t; vector<int> v; v.push_back(0);
for (int i = 1; i <= N; i++)

scanf("%d", &t);
v.push_back(v[i - 1] + t);

int l = 0, h = N;
map<int, int>ma;
int mid;
int min1 = 1000000000; int minmin = 1000000001;
for (int i = 0; i <=N; i++)

l = i; h = N;
while (l <= h)

mid = (l + h) >> 1;
int temp = v[mid] - v[i] - M;
if (temp < 0)

l = mid + 1;

else if (min1 > temp)

min1 = temp;
h = mid - 1;

else
h = mid - 1;

minmin = min(min1, minmin);
//先二分找出离M最小的差距
for (int i = 0; i <= N; i++)

l = i; h = N;
while (l <= h)

mid = (l + h) >> 1;
int temp = v[mid] - v[i] - M;
if (temp < minmin)

l = mid + 1;

else if (minmin== temp)

ma[i + 1] = mid;
break;

else
h = mid - 1;

//再二分找出所有这样的对
for (map<int, int>::iterator it = ma.begin(); it != ma.end(); it++)

printf("%d-%d\\n", it->first, it->second);

return 0;


以上是关于PAT甲级1044的主要内容,如果未能解决你的问题,请参考以下文章

PAT 甲级 A1044 (2019/02/20)

PAT甲级1044 Shopping in Mars (25 分)(前缀和,双指针)

PAT乙级1044

pat甲级75分在啥水平

pat甲级没做出来没有分吗

pat甲级60分啥水平