PAT甲级1031

Posted wx630c98f24f6b8

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级1031相关的知识,希望对你有一定的参考价值。


1031. Hello World for U (20)


时间限制



400 ms



内存限制



65536 kB



代码长度限制



16000 B



判题程序



Standard



作者



CHEN, Yue


Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:



h d e l l r lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n

1 characters, then left to right along the bottom line with n

2 characters, and finally bottom-up along the vertical line with n

3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n

1 = n

3 = max k| k <= n

2 for all 3 <= n

2 <= N with n

1 + n

2 + n

3 - 2 = N.


Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.


Sample Input:


helloworld!


Sample Output:


h ! e d l l

lowor

#include<stdio.h>
#include<iostream>
#include<string>
#include<map>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;

int main()

string s;
cin >> s;
int N = s.size();
if (N < 7)

cout << s[0];
for (int i = 0; i < N - 4; i++)
cout << " ";
cout << s[N - 1] << endl;
for (int i = 1; i < N - 1; i++)
cout << s[i];
cout << endl;

else

int rows = (N + 2) / 3;
for (int i = 0; i < rows; i++)

cout << s[i];
for (int j = 0; j < N - 2 * rows; j++)

if (i != rows - 1)
cout << " ";
else
cout << s[rows + j];

cout << s[N - 1 - i] << endl;


return 0;



以上是关于PAT甲级1031的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲级——A1031 Hello World for U

PAT甲级1031 Hello World for U (20 分)

pat甲级75分在啥水平

pat甲级没做出来没有分吗

pat甲级60分啥水平

PAT乙级1031