PAT甲级1085
Posted wx630c98f24f6b8
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级1085相关的知识,希望对你有一定的参考价值。
1085. Perfect Sequence (25)
时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng
Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8 2 3 20 4 5 1 6 7 8 9
Sample Output:
8
#include<iostream>
#include<cstdio>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
int main()
int N;
long long p;
cin >> N >> p;
vector<long long> v;
long long t;
for (int i = 0; i < N; i++)
cin >> t;
v.push_back(t);
sort(v.begin(), v.end());
int len = 0;
for (int i = 0; i < N; i++)
for (int j = len+i; j < N; j++)//利用上次计算的信息
if (v[i]*p < v[j])
break;//该中断时中断,后续比较无用
if (len < j - i + 1)
len = j - i + 1;
cout << len;
return 0;
以上是关于PAT甲级1085的主要内容,如果未能解决你的问题,请参考以下文章