YTU 2432: C++习题 对象数组输入与输出
Posted wx62f237590ad0d
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了YTU 2432: C++习题 对象数组输入与输出相关的知识,希望对你有一定的参考价值。
2432: C++习题 对象数组输入与输出
时间限制: 1 Sec
内存限制: 128 MB
提交: 1603
解决: 1152
题目描述
建立一个对象数组,内放n(n<10)个学生的数据(学号、成绩),用指针指向数组首元素,输出第奇数(1,3,5,7)个学生的数据。
输入
n和n个学生的学号、成绩
输出
奇数学生的数据
样例输入
5
101 78.5
102 85.5
103 98.5
104 100.0
105 95.5
样例输出
101 78.50
103 98.50
105 95.50
提示
主函数已给定如下,提交时不需要包含下述主函数
/* C++代码 */
int main()
const int NUM=10;
Student stud[NUM];
int n,i;
cin>>n;
for(i=0; i<n; i++)
stud[i].input();
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
Student *p=stud;
for(i=0; i<n; p+=2,i+=2)
p->display();
return 0;
迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……
#include <stdio.h>
#include <iostream>
#include <iomanip>
using namespace std;
class Student
public:
void input()
cin>>num>>a;
void display()
cout<<num<<" "<<a<<endl;
int num;
float a;
;
int main()
const int NUM=10;
Student stud[NUM];
int n,i;
cin>>n;
for(i=0; i<n; i++)
stud[i].input();
cout<<setiosflags(ios::fixed);
cout<<setprecision(2);
Student *p=stud;
for(i=0; i<n; p+=2,i+=2)
p->display();
return 0;
以上是关于YTU 2432: C++习题 对象数组输入与输出的主要内容,如果未能解决你的问题,请参考以下文章