POJ 1704:Georgia and Bob

Posted wx62f237590ad0d

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1704:Georgia and Bob相关的知识,希望对你有一定的参考价值。


Georgia and Bob


Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 9321

 

Accepted: 3036


Description


Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 


POJ


Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 



Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 



Given the initial positions of the n chessmen, can you predict who will finally win the game? 




Input


The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.



Output


For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise Not sure.



Sample Input


23 1 2 3 8 1 5 6 7 9 12 14 17



Sample Output


Bob will winGeorgia will win



给一个1*M的棋盘,上面有N颗棋子,每次只能向左移动棋子,并且至少移动一步,两人轮流操作,谁不能移动谁就输了。

很明显的博弈问题,我们可以把整个棋盘中相邻棋子之间的距离计算出来,人为操作可能会使这个距离增大,也可能会让它减小,但是,每两次操作中,不论如何移动棋子,我们都可以假设这个距离一定会减小,这样的话,这个距离就相当于石子的数量,两人轮流取走石子,看谁取走最后的石子啦!问题就这样转换成了Nim博弈,但是如果棋盘上的棋子数量是奇数应该怎么办呢?我们可以添加一个棋子,在棋盘的最左端,也就是它的位置是0,每堆石子的数量可认为是相邻每两个棋子的距离差,然后计算异或,判断数值之后得出结果。


AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int main()

int t;
cin>>t;
while(t--)

int n;
cin>>n;
int a[n+10],s=0;
for(int i=0; i<n; i++)
cin>>a[i];
if(n&1)a[n++]=0;
sort(a,a+n);
for(int i=1; i<n; i+=2)
s^=a[i]-a[i-1]-1;
if(s)cout<<"Georgia will win"<<endl;
else cout<<"Bob will win"<<endl;

return 0;

以上是关于POJ 1704:Georgia and Bob的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1704 Georgia and Bob

POJ 1704 Georgia and Bob(阶梯博弈+证明)

POJ 1704 Georgia and Bob(阶梯博弈)

POJ1704 Georgia and Bob(Staircase Nim)

POJ1704 Georgia and Bob (阶梯博弈)

POJ1704Georgia and Bob(博弈论)