POJ - 1502MPI Maelstrom(Dijkstra单源最短路--求一点到其余个点的最小值的最大值)

Posted wx62a8776062513

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ - 1502MPI Maelstrom(Dijkstra单源最短路--求一点到其余个点的最小值的最大值)相关的知识,希望对你有一定的参考价值。

题干:

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKees research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform, Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet. 

``How is Apollos port of the Message Passing Interface (MPI) working out? Swigert asked. 

``Not so well, Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance. 

``Is there anything you can do to fix that? 

``Yes, smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on. 

``Ah, so you can do the broadcast as a binary tree! 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages dont necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input


5 50 30 5 100 20 50 10 x x 10

Sample Output


35

题目大意:

给你一个不完全的矩阵(下三角形),数字表示权值,x表示两点间不可达
由于自身到自身花费的时间为0,所以没有给出,由于i到j和j到i距离相同,互达时间相同
所以只给出了一半的临界矩阵。
根据给你的这个临界矩阵,让你来求从点1到其他点所花费最短时间集里面的的最大值。
其实这是一个很直接的最短路

解题报告:

     用o(n^2)的方法,邻接矩阵储存图,给一个下三角形矩阵,字符串读入,用get函数处理一下成int型权值,然后跑一边Dijkstra,再看从点1可以跑到那个点是最大值即可。

 

AC代码:

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
const int MAX = 100000 + 5;
const int INF = 0x3f3f3f3f ;
int vis[MAX];
int maze[105][105];
int n,m;
int dis[MAX];//表示从出发点开始到该点的最短距离。

void Dijkstra(int u,int v)
dis[u] = 0;
int all = n,minw = INF,minv;//这里的初始化还是有讲头的。
for(int k = 1;k<= n;k++)
minw = INF;
for(int i = 1; i<=n; i++)
if(vis[i] ) continue;
if(dis[i] < minw)
minv = i; minw = dis[i];


vis[minv] = 1;
// if(minv == v) break;
for(int i = 1; i<=n; i++)
if(vis[i]) continue;
if(maze[minv][i] == 0) continue;
dis[i] = min(dis[i], dis[minv] + maze[minv][i]);



int get(char *s)
if(s[0] == x) return INF;
int len = strlen(s);
int ans = 0;
for(int i = 0; i<len; i++)
ans = ans*10 + s[i]-0;

return ans;

int main()

int a,b;
char w[20];
while(~scanf("%d",&n) )
memset(dis,0x3f3f3f3f,sizeof(dis) ) ;
memset(maze,0,sizeof(maze) );
memset(vis,0,sizeof(vis) ) ;
for(int i = 2; i<=n; i++)
for(int j = 1; j<i; j++)
scanf("%s",w);
maze[i][j] = maze[j][i] = get(w);


Dijkstra(1,n);
int ans = *max_element(dis+1,dis+n+1);
printf("%d\\n",ans);

return 0 ;

 

 总结:

     只要改一下模板,不让他在(minv == v) 的时候break掉就可以。并且此时传入的v没有任何卵用了。。。

     即 其实你传入的v也只有在这个判断的时候有用啊,其他时候你看模板里面都没有v出现。所以针对这个题我们只需要不让他在minv==v的时候停止,而是继续跑程序,就可以了。最后输出最大值。


以上是关于POJ - 1502MPI Maelstrom(Dijkstra单源最短路--求一点到其余个点的最小值的最大值)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1502 MPI Maelstrom (最短路)

MPI Maelstrom POJ - 1502 最短路Dijkstra

POJ-1502-MPI Maelstrom

POJ1502 MPI Maelstrom

MPI Maelstrom POJ - 1502 floyd

POJ1502 MPI Maelstrom Dijkstra