POJ - 2236Wireless Network (并查集)

Posted wx62a8776062513

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ - 2236Wireless Network (并查集)相关的知识,希望对你有一定的参考价值。

 题干:

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题目大意:

   先给出一些点(的坐标x和y),接下来有两种操作  O代表修复一个点。S代表测试当前情况下是否两者已经连上。有一个计算机网络的所有线路都坏了,网络中有n台计算机,现在你可以做两种操作,修理(O)和检测两台计算机是否连通(S),只有修理好的计算机才能连通。连通有个规则,两台计算机的距离不能超过给定的最大距离D(一开始会给你n台计算机的坐标)。检测的时候输出两台计算机是否能连通。

解题报告:

   不算难啊这题,但是要注意,你能并起来的前提是这个电脑已经被修好了,所以用ok[ top ]记录一下已经被修好的电脑的下标。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const double eps = 1e-6;
int ok[1000 + 5];//代表已经修好的点 存标号即可 然后再结构体查询
int f[1000 + 5];
int n,d;
struct Node
double x,y;

node[1000 + 5];
int getf(int v)
return v==f[v]?v:f[v]=getf(f[v]);


void merge(int u,int v)
int t1=getf(u);
int t2=getf(v);
if(t1!=t2)
f[t2]=t1;



double dis(Node a,Node b)

return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));

void init()
for(int i = 1; i<=n; i++)
f[i]=i;


int main()

int u,v;
int top=0;
char op[5];
cin>>n>>d;
init();
for(int i = 1; i<=n; i++)
scanf("%lf %lf",&node[i].x,&node[i].y);

while(~scanf("%s",op) )
if(op[0]==O)
scanf("%d",&u);
for(int i = 1; i<=top; i++) //因为只能与修复的电脑进行连接
if(dis(node[ok[i] ] ,node[u] ) - d < eps)
merge(ok[i],u);


ok[++top] = u;

else
scanf("%d %d",&u,&v);
getf(u) == getf(v) ? printf("SUCCESS\\n") : printf("FAIL\\n");


return 0 ;

总结:

   这题有一个技巧,ok数组存的是结构体下标,而不是另开一个ok结构体,这增强了代码的可读性与节省了空间。


以上是关于POJ - 2236Wireless Network (并查集)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2236Wireless Network [并查集]

POJ - 2236Wireless Network (并查集)

POJ - 2236Wireless Network (并查集)

poj 2236并查集

并查集 poj2236

POJ-2236(并查集)