Happy 2006 欧几里得定理

Posted joeylee97

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Happy 2006 欧几里得定理相关的知识,希望对你有一定的参考价值。

Happy 2006
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 11956   Accepted: 4224

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

Source

 

 

周期性!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long LL;
#define MAXN 1000002
/*
要求找到与m互质的第k大的数字
gcd(a,b) = gcd(b*t+a,b)
*/
LL a[MAXN];
LL gcd(LL a,LL b)
{
    if(b==0)
        return a;
    return gcd(b,a%b);
}
int main()
{
    LL m,k;
    while(scanf("%lld%lld",&m,&k)!=EOF)
    {
        LL p=0;
        for(int i=1;i<=m;i++)
        {
            if(gcd(i,m)==1)
                a[++p] = i;
        }
        if(k%p==0)
            printf("%lld\n",(k/p-1)*m+a[p]);
        else
            printf("%lld\n",(k/p)*m+a[k%p]);
    }
}

 



以上是关于Happy 2006 欧几里得定理的主要内容,如果未能解决你的问题,请参考以下文章

poj2773Happy 2006 欧几里德

欧几里德算法POJ2773-HAPPY 2006

HDU 1452 Happy 2004(唯一分解定理)

poj 2773 Happy 2006

POJ2773 Happy 2006GCD+枚举

欧几里得(辗转相除gcd)扩欧(exgcd)中国剩余定理(crt)扩展中国剩余定理(excrt)简要介绍