编程:有三个整数a.b.c由键盘随机输入,输出其中最大的数
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了编程:有三个整数a.b.c由键盘随机输入,输出其中最大的数相关的知识,希望对你有一定的参考价值。
--------------NO.1----------------c语言:
int max(int a,int b,int c)
int t;
if(a>b)
t=a;
else t=b;
if(t<c)
t=c;
return t;
main()
int a,b,c,t;
scanf("%d,%d,%d",&a,&b,&c);
t=max(a,b,c),
printf("max=%d",t);
-------------NO.2----------------
#include <iostream>
using namespace std;
int GetMax(int a, int b, int c)
int max = a;
if(a<b)
max = b;
if(b<c)
max = c;
else
if(a<c)
max = c;
return max;
int main()
int a, b, c;
int maxNum;
a = 4;
b = 6;
c = 10;
maxNum = GetMax(a, b, c);
cout << maxNum << endl;
return 0;
这个是C++的格式
要是c的话 把cout 换成 printf就行了
函数GetMax()用了最容易理解的方法 里面还可以改成逗号表达式应该也没问题的
--------------NO.3--------------------
#include<iostream.h>
main()
int a,b,c,temp,max;
L: cout<<"输入第一个整数:";
cin>>a;
cout<<endl;
cout<<"输入第二个整数:";
cin>>b;
cout<<endl;
cout<<"输入第三个整数:";
cin>>c;
cout<<endl;
if(a>b)
temp=a;
else
temp=b;
if(temp>c)
max=temp;
else
max=c;
cout<<"最大的数为:"<<max<<endl;
goto L;
输入第一个整数:589
输入第二个整数:154
输入第三个整数:487
最大的数为:589 参考技术A #include<iostream.h>
main()
int a,b,c,temp,max;
L: cout<<"输入第一个整数:";
cin>>a;
cout<<endl;
cout<<"输入第二个整数:";
cin>>b;
cout<<endl;
cout<<"输入第三个整数:";
cin>>c;
cout<<endl;
if(a>b)
temp=a;
else
temp=b;
if(temp>c)
max=temp;
else
max=c;
cout<<"最大的数为:"<<max<<endl;
goto L;
参考技术B 用C++也可以:
#include <iostream>
using namespace std;
void main()
int a,b,c,max;
cout<<"输入三个数:";
cin>>a>>b>>c;
if(a>b&&a>c)
cout<<"最大数为"<<a;
else if(b>a&&b>c)
cout<<"最大数为"<<b;
else if(c>a&&c>b)
cout<<"最大数为"<<c;
else if(a=b=c)
cout<<"三个数相等!;
参考技术C 键盘随机输入,也就是手动喽?
pascal语言
var a,b,c,max:longint;
begin
max:=-maxlongint;
read(a);
if a>max then max:=a;
read(b);
if b>max then max:=b;
read(c);
if c>max then max:=c;
writeln(max);
end.
Codeup
问题 D: 习题4-4 三个整数求最大值
时间限制: 1 Sec 内存限制: 12 MB提交: 815 解决: 727
[提交][状态][讨论版][命题人:外部导入]
题目描述
有3个整数a, b, c,由键盘输入,输出其中最大的数。
输入
以空格分割的三个整数。
输出
三个数中的最大值,末尾换行。
样例输入
1 3 2
样例输出
3
1 #include <stdio.h> 2 int main(){ 3 int a,b,c,max; 4 scanf("%d %d %d",&a,&b,&c); 5 if(a>max){ 6 max = a; 7 } 8 if(b>max){ 9 max = b; 10 } 11 if(c>max){ 12 max = c; 13 } 14 printf("%d",max); 15 return 0; 16 }
以上是关于编程:有三个整数a.b.c由键盘随机输入,输出其中最大的数的主要内容,如果未能解决你的问题,请参考以下文章
编程实现:由系统生成一个10以内的随机整数,用户从键盘上输入一个10以内的整数,如果两者相等输出“OK”
怎么使用java编程: 1、 随机产生一个1-100(小于100)内的整数,由用户通过键盘输入来猜,当从
用指针实现:由键盘输入10个整数,将他们按由小到大的顺序排列。
编程:从键盘输入一个整数值k,再循环输入k个整数num,统计其中正数、零和负数的个数,分别存于整形